CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Running Multiple Simulations from Workbench 12.1 (

Josh August 9, 2010 16:08

Running Multiple Simulations from Workbench 12.1
Hello all -

I have multiple licenses available from CFX. I am using a separate license for each application so that I can run multiple applications at once from Workbench 12.1. Currently, I have a Workbench project with two different simulations (A and B). I can open several instances of CFD-Pre, -Post, and ICEM, as desired. However, I cannot seem to open up anything new once a simulation is running in Solver. For example, when I'm running simulation A in Solver, nothing happens when I double-click CFD-Pre in simulation B. My mouse indicates a busy signal (hourglass) and I cannot open anything while a simulation is running.

Is it possible to run multiple simulations simultaneously from Workbench? I know you can outside of Workbench, but I enjoy using Workbench.


mvoss August 10, 2010 02:41

maybe this might help:
right click above the solution branch --> switch active task to background.


Josh August 10, 2010 11:40

Thanks for the response, Neewbie.

I was able to open two solvers at once (one each for simulations A and B). I ran A, then attempted to run B. A ran successfully, but B turned up a licensing error.

I know I have 5 licenses available for use. I see them on the server utility and I'm able to open 5 instances of any CFX program. However, it doesn't seem to allow me to actually run 2 simulations from the same Workbench project at the same time.

Do you think I could fix the problem by having two separate Workbench files rather than one Workbench file with two simulations on it? Is it hopeless to run two simulations simultaneously in Workbench?

Josh August 10, 2010 19:51

I have fixed the problem, but I don't know how I did it. Neewbie's suggestion allowed me to open two simulations, though the first time I tried running them both in parallel, I received a licensing error. This time, I ran one in parallel, one in serial, and it worked. Not sure why. I have 5 licenses.


All times are GMT -4. The time now is 05:24.