CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   How to run ".def" model with parallel CPUs (

mohammad January 4, 2011 05:12

How to run ".def" model with parallel CPUs
Hi every body.
I have created a model with CFX and want to run it with 4 processors.
when I try with "serial" option, it works but according to my model it takes a long time to be solved.
When I try using "MPICH2 local paralle" it fails always. The error is:

! Error #001100279 has occurred in subroutine ErrAction.
! Message:
! Incompatible sparsity patterns.

Does anybody know why? Is there any brave-heart to help me? :)

AliTr January 5, 2011 18:51

Are you able to run CFX examples in parallel?

If yes, do you receive this error during partitioning?

mohammad January 6, 2011 01:05

Hi Ali,
I tried to solve some other CFD files in parallel and I was successful.
Plus,for your second question, when I run the file it works for some few iteration( usually less than 10 iterations) , and I don't have any problem during the partitioning stage.
So do you have any idea about that?


AliTr January 6, 2011 21:12

Then "Incompatible sparsity patterns" makes me thinking somethig went wrong in solver side, did you try to alter the mesh either finer or courser which might change the sparsity patern?

mohammad January 7, 2011 05:05

Hi dear Ali,
Actually, I changed my software again to Ansys 11 not 12. Now I'm trying to solve that problem...
You know,I'm trying to solve a wind tunnel and even for the same model, when i change wind velocity iwill have different errors..
I think that's normal because I must change my mesh arrangement, specially near the blade.
By the way! do you have any experience about wind turbine in CFD? :)
If yes, I want to talk with you about the proper turbulent model and mesh arrangement.


AliTr January 10, 2011 19:00

unfortunately wind turbines are not my field, I did model some wind farms but that didn't include the turbine's details. you might look around and find some close example helping you on that.

All times are GMT -4. The time now is 14:01.