CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   ANSYS and CFX not talking in two-way FSI? (

brashear January 27, 2011 04:16

ANSYS and CFX not talking in two-way FSI?
I get the following error when I try to update my CFX-Pre:

In Analysis 'Flow Analysis 1' - Analysis Type: The specified Mechanical Input File 'ds.dat' can not be found or does not contain any valid interfaces. Specify an input file with valid interfaces, update the file location if it has moved or set the External Solver Coupling option to "ANSYS MultiField via Prep7".

I started the FSI analysis by starting an ANSYS transient analysis, which I confirmed to be solvable by itself. Then I deleted the results then to "Transfer Data to New -> Fluid Flow (CFX)" from the setup. I defined my fluid-structure interface loads in ANSYS.

I tried pointing manually to the 'ds.dat' file under dir\dp0\SYS\MECH\ds.dat, but the same error results.

Any thoughts? :confused: Thanks

stumpy January 31, 2011 12:17

In the Project Schematic delete the link between the ANSYS Setup cell and the CFX Setup cell, then re-create it and refresh CFX-Pre. That usually fixes this problem for me.

et1ap2 May 5, 2012 07:32


I have the same problem as brashear. I tried to delete and re-create the link between setup cells of ANSYS and CFX, but the error still exists :( Do you have any other suggestions? Thanks in advance

sajad_abasi May 5, 2012 10:49

i had this problem too.but i saved it in this manner and closed workbench after that i open it again and it works right.
sometimes you should specify the file path yourself for the software

hope to help you

Gweher May 5, 2012 22:17

As Stumpy said it should work (always does for me).

If not I think you should try, >Project Directory\dp0\CFX\CFX, and use the ./ds in CFX so you have no issues when changing the project directory path.

Alanseu June 13, 2012 05:15

Actually it is the missing of FSIN_No# in defining the boundary of Interface of fluid and solid in CFX-re, which cause the ds.dat cannot been found or others.

SteelMan November 25, 2012 09:13

I met the same problem. I copied the ds.dat into the target folder from an old project and it works. I checked the contents of the file(ds.dat )and it was updated according to new project.

All times are GMT -4. The time now is 23:54.