CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   not all memory is used (

Romek March 17, 2011 22:48

not all memory is used

I am trying to run a simulation with Ansys 13 on a Server with 16gb memory.

The simulation requires about 12gb, but i cant run is. It says not enough free memory allocated. Then I reduced the solver memory allocation step by step to 0.7 where it needs about 8.5gb memory, but same problem appears.
I can run a smaller simulation with 7gb memory allocated.

Why cant I use the whole 16gb (minus what the OS needs)?
Is it an Ansys settings problem?

Romek March 22, 2011 20:53

please does someone have a hint?

i still didn't figure out how to solve this problem. The system is running on Windows Server 2008 R2.

i can run a simulation with 2 fluid domains and 2 fluids specified (needs ~8gb). When i try to add a 3rd domain and a 3rd fluid it's not working for the reason i mentioned. I have enough memory available.

if you need more information just tell me

ghorrocks March 22, 2011 22:28

Are you running CFX or ANSYS FEA?

In CFX you can always just do a parallel simulation and bring the memory problems under control that way.

Romek March 22, 2011 23:04

I'm running CFX in HP MPI local parallel mode with double precision.

I tried to go down with the solver memory allocation factor as far as possible but no luck...

stumpy March 23, 2011 09:13

It not enough memory has been allocated then you should increase the memory allocation factor, not decrease it. If not enough memory was available then that's a different problem. How many partitions are you using? If it's allocating more than 4GB per partition for any single stack then it could be due to a bug - contact support for a fix.

Romek March 24, 2011 00:02

thank you so much, i solved the problem with your help!

I didn't have a partition problem before. The partitions were indeed larger than 4gb because I was using 2 partitions.

Increasing the number of partitions finally made the solver run...

I can use 3 or 4 partitions (more has got me license issues), which number is better? I'd say 3 is better due to less larger stacks, right?

joey2007 March 24, 2011 14:28

Unless you are above 100k-200k nodes per partition you can use as much partitions as possible. Below this number of nodes per partition it will get inefficient.

On quad core machines the band width to memory may be a bottle neck. Recommendation: on many machines it will be siginificantly more efficient to use only three of four cores.

Romek March 24, 2011 20:36

I have got 1.5m nodes and 3 partitions is about 6% faster per iteration step than 4 partitions. Just tested on 1st time step!

joey2007 March 25, 2011 14:46

Roughly spoken: the solution process is parallized. Anything before and after is done by the master process alone. In order to measure the speedup you have to compare wall clock time of the solution process. Otherwise the i/o will bias the result.

makkks July 7, 2011 19:38

Hi Guys,

I m using Ansys 13 SP2, 256GB ram, 48 core .
the simulation is giving memory allocation error.
sum Errors are not even on CFD site like:

Stopped in routine MEMPAR
Stopped in routine ILOCCS

I tried to change d factor in partitioner, solver but nothign is helping.

sometimes it is saying
"not enough memory was available"

what should I do?

I m using MPCH2 LOcal Parallel with 44core for this simulation.
seems each core is picking 8GB
reducing slover allocation factor is not working,

Plz help

ghorrocks July 8, 2011 06:58

You have some serious hardware available there. Have you tried doing test runs with smaller numbers of processes?

makkks July 10, 2011 18:21

Thanks for the reply Glen,

yup I have tried to use it with small processes and it works fine.

Also, I just tried running again and changed the Partitioner to 0.8x , Solver to 0.4x, Interpolator to 0.4x and finally it started running but after 2 steps it stopped and gave error again saying

Stopped in routine MEMERR.

It used upto 120GB memory and 48 cores in the above process.

ghorrocks July 10, 2011 19:04

I do not have access to that many processors or licenses. You are seeing problems I cannot possibly see, so I do not think I can help you. As you must have a significant investment in this setup I would contact CFX support for help to get it running ASAP.

makkks July 10, 2011 19:07

Thanks a lot for your support Glen :)

All times are GMT -4. The time now is 22:39.