CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Problem to get the double precision (

c120613 May 2, 2011 19:48

Problem to get the double precision
Hi All,

in some simulation with CFX solver at the beginning of the job I got the following line:

Does anyone knows how I can get back to the double precision?

Thank you in advance


ghorrocks May 2, 2011 23:11

In the solver manager select the double precision solver. Or if running from the command line use the -double flag. Or stick a item in the CEL in /SIMULATION CONTROL/EXECUTION CONTROL/EXECUTABLE SELECTION/Double precision = on

Any of these options will work.

Julian K. January 24, 2012 10:09


I solved the problem by activating "Execution Control > Run Definition > Executable Selection > Double Precision" in the CFX-Pre GUI.

c120613 January 24, 2012 10:18

double precision

in some cases, particularly when the definition file is too big that option goes back to OFF automatically. Although you change that option from the interface does not work anyway. Have you never gone through this problem so far?


ghorrocks January 24, 2012 17:42

I have never seen it turn double precision off because it got too big. I have generated def files with double precision which have been too big to run many times so I doubt what you are saying. Sounds like it flipped back to single precision for another reason.

Lance January 26, 2012 09:07

Sometimes I get the same error:

| |
| CFX Command Language Upgrade |
| |

Precision = Off.

CONTROL/PARALLEL ENVIRONMENT/Number of Processes since we are in
Distributed Parallel mode.

even though I start with the -double switch from the command line. However, I still think that the solver runs with double precision because later on the in the outfile is:

| Mesh Statistics |
| Domain Name | Orthog. Angle | Exp. Factor | Aspect Ratio |
| | Minimum [deg] | Maximum | Maximum |
| Default Domain | 17.5 ! | 7 ok | 3439 OK |

For single precision runs the limit for an "OK" for Aspect Ratio is < 100 while for double precision it is < 10000, and since I get an "OK" for 3439 I assume (hope?) that is runs in double.

ghorrocks January 26, 2012 17:22

I did not know that. That must be a new feature they snuck in a recent release. Thanks for the info Lance.

derz July 8, 2014 05:54

Hey guys, just wanted to add something here.

I had this problem yesterday...I selected double precision EVERYWHERE possible, even the "Override default" selections, but it kept solving in Single Precision mode. It actually said "Double Precision - On" in the output file towards the top, and then later down decided "Double Precision - Off" was what it wanted to do, for no reason...

I talked to my colleague and he had a similar problem once, and said after rebooting the computer the solver stopped putting in extra lines that no-one requested, so I tried that and, low and behold, it is now solving in double precision.

So bare that in mind...erroneous precision switching may just be some problem that has developed during the many runs preceding it - a Restart is all that's required.

All times are GMT -4. The time now is 16:19.