CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Initialization error (

cprasad111 June 8, 2011 03:12

Initialization error
Multiphase model

Geometry is simple. A rectangle divided into two domains 1 and 2 seprated by an interface.

Two mixtures are created "kerosene phase" having components "kerosene" n "aceticacid" AND "water phase" having components "water" n "aceticacid".

Initial Condition:
In domain 1: there is only kerosene phase with known acetic acid mass fraction. (kerosene is contraint)
In domain 2: there is only water phase with known acetic acid mass fraction. (water is constraint)

CFX initialization i have done:

kerosene phase-volume fraction :1
acetic acid-mass fraction:0.009

water phase-volume fraction:0
acetic acid -mass fraction:0

now when i monitored mass fraction of water of water phase in domain 1 its showing 1 and not 0.

Although i have specified water phase volume fraction to be 0, the mass fraction of water is being calculated from the constraint i.e. 1-acetic acid mass fraction(=0) which gives 1.But i want water mass fraction in domain 1 to be 0.

I must be doing some mistakes.

plz help

ghorrocks June 8, 2011 06:43

It sounds like everything is a liquid. This means it is not a multiphase model. Why did you choose a multiphase model?

cprasad111 June 8, 2011 07:50

water phase and kerosene phase are immiscible, so, i am using multiphase model. And initially acetic acid is present only in kerosene phase which by diffusion transfers to the water phase.

ghorrocks June 8, 2011 08:00

And the boundary between the domains - do the kerosene and water mix, or are they kept separate?

Are you using a free surface model or some other eularian model for the kerosene/water mixture?

cprasad111 June 8, 2011 08:08

kerosene and water does not mix. I am using free surface model.

Earlier I tried it as single phase model, and the boundary between domains were specified as wall, such that water and kerosene does not mix. For acetic acid, mass transfer was forced by adding source terms subdomain.This worked but the concentration of acetic acid changes in the whole domain at once. But this model does not allow natural diffusion of acetic acid from kerosene to water neither convetion diffusion in the domain.

I also tried adding source terms to the domain-boundary instead but this did not work.

ghorrocks June 8, 2011 20:54

Does the interface between the water and kerosene move?

Your comment about the source term - then just apply the source term to the interface/boundary. Obviously you cannot apply the source term to the whole domain.

cprasad111 June 9, 2011 01:06

Interface does not move.

I tried applying source term to the boundary/interface, but in that case the result is not good its weired. I'll try that again and see what is the result.

cprasad111 June 9, 2011 01:21

for the boundary source i have two options, which do you think should be used

1. k*((ave(reactant.molconc)@Boundary 1)-(ave(reactant.molconc)@Boundary 2))*

2. k*((ave(reactant.molconc)@Domain1)-(ave(reactant.molconc)@Domain2))*

k is some appropriate term

Domain 1 is the left part of the rectangle and domain 2 is the right half. The common boundary has between the domains has boundary 1 in domain 1 and boundary 2 in domain 2

ghorrocks June 9, 2011 06:50

If the boundary does not move then do not use a multiphase approach. Use two single phase domains (there is an expert parameter to allow you to put different fluids in separate domains, do a search of the forum to find it), and connect them with an interface. Turn off the p/mom interface, but define your own mass fraction equation. Then you do not need multiphase models.

For your transfer equation why are you using average concentrations? Surely the important thing is the local concentration at either side of the interface. You will have to use some sort of mass fraction interface to do this I think.

cprasad111 June 9, 2011 07:05

Thankyou very much for you reply

I tried with the source term to the interface (the 1st choice from my previous reply) and its working almost fine. I also found out why it did not work earlier(probably due to wrong i.e. very high k value)

Now, to make the model better, I will try to find that expert parameter and other usefuls tips as metioned by you.

Thanks once again

All times are GMT -4. The time now is 08:00.