CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Ansys 13 CFX problem on LInux Opensuse 11.4 (

serendipity June 9, 2011 10:02

Ansys 13 CFX problem on LInux Opensuse 11.4
I installed Ansys 13 on Linux Opensuse 11.4. I launch Workbench, I create geometry with DM and i generate the mesh successfully. Then I start Ansys CFX Pre It starts but it hangs with the process bar on completing at 100%. So I have to kill CFX Pre. When I return to Workbench window I get this error:

System.ApplicationException: Error importing meshes. CFX-Pre exited unexpectedly.
at Ansys.CFX.Foundation.App.ApplicationProxy.HandleEr rorCondition (CommandResult result, System.String msg) [0x00000]
at Ansys.CFX.Foundation.App.CUEApplicationProxy.Handl eErrorCondition (CommandResult result, System.String msg) [0x00000]
at Ansys.CFX.CFXCore.App.CFXPreProxy.UpdateMesh (IFullContext context, Int32 id, System.String fileName, ImportableMeshType fileType) [0x00000]
at Ansys.CFX.CFXCore.Data.CFXSetupSource.UpdatePreMes hes (IFullContext context) [0x00000]
at Ansys.CFX.CFXCore.Data.CFXSetupSource.LoadEditorDa ta (IFullContext context, Boolean interactive, Boolean dedicated) [0x00000]
at Ansys.CFX.Foundation.Data.CUESourceDataObject.Edit (IFullContext context, Boolean interactive) [0x00000]
--- Ansys.Core.Commands.CommandFailedException: Error importing meshes. CFX-Pre exited unexpectedly.
CommandName: CFX.EditSetup(Container="Setup")
at Ansys.Core.Commands.CommandAsyncResult.RethrowFail ureException (System.Exception e) [0x00000]
at Ansys.Core.Commands.CommandAsyncResult.Wait (Int32 milliSecondsTimeout, Boolean exitContext) [0x00000]
at Ansys.Core.Commands.CommandAsyncResult.Wait () [0x00000]
at Ansys.CFX.CFXCore.Commands.EditSetupCommand.Invoke AndWait (IProtectedContext context, Ansys.Core.DataModel.ProjectSystem.DataContainerRe ference Container, Boolean Interactive) [0x00000]
at Ansys.CFX.CFXCore.Commands.EditSetupGui.Invoke (Ansys.UI.GuiOperationContext context) [0x00000]
at Ansys.UI.GuiOperationContext.Invoke (Ansys.UI.GuiOperationMetaData operationData) [0x00000]
at Ansys.UI.UIManager+<InvokeOperation>c__AnonStorey3 5.<>m__1D () [0x00000]
at Ansys.UI.UIManager.InvokeOperationCore (System.String pseudoname, Ansys.UI.Views.OperationDelegate callback, Boolean allowOSMessages, Boolean coreTransaction) [0x00000]

How can I fix this problem?

i hope I will not have problem with CFX Solver and CFX Post



MainzerKaiser July 18, 2011 12:00

Was that problem already solved? I would be interested how!!

this thread is also discussing the problem:

if you use the presented hint:
gedit /home/localuser/.cfx/CFXPreferences.ccl

Automatic Physics Update = On -> Off
Physics Validation Disabled = Off -> On

, then you can use cfx-pre, but it is not possible to save or close it again without:
ERROR CCL database failed with message: getStringValue: value "/COLOUR MAP DEFAULT:Default Colour Map/Colour Map Nae" does not exist

I wrote an request to the support, I hope, they answer soon!

my system: openSUSE 11.4, nVidia GF 9500GT

alquimista October 13, 2011 07:19

I have the same problem, I have read all the posts but I can't find a solution!

Has anyone successfully resolved it?

Trying to install Ansys 13 in OpenSuse 11.4 (x86_64) with GeForce GTX 550 Ti.

SO: Linux x86_64
KDE: 4.6.00 (4.6.0) "release 6"
CPU: Intel(R) Xeon(R) CPU E5645 @ 2.40GHz

MainzerKaiser October 13, 2011 07:23

I "solved" the problem by going back to openSuse 11.2.
The 11.4. version is to young to be supported by Ansys. Btw openSuse is not the officially supported enterprise version, so usually there is no support at all...

At the end of the year Ansys 14 is going to support Suse 11.4. At least this is, what I heard...

alquimista December 21, 2011 12:12

Has someone try to install it in openSUSE 12.1? Are there some errors?


charlotte December 21, 2011 17:41

ANSYS 13 is not compatible with Opensuse 11.4 and Opensuse 12.1 (the kernel version of these 2 distributions are too recent for ANSYS 13).

ANSYS 14 may be compatible with 11.4, but I'm pretty sure it is not with openSUSE 12.1 (kernel 3... way too advanced for ANSYS)


Originally Posted by alquimista (Post 336633)
Has someone try to install it in openSUSE 12.1? Are there some errors?


alquimista December 22, 2011 08:26

Thank you charlotte! It's not so easy to remain the computer up to date with that kind of software.

ghorrocks December 22, 2011 16:51

It is not difficult. ANSYS has supported and tested OS. The current version (V14) is on the website, and you can get older versions by asking support.

alquimista December 22, 2011 17:51

@ghorrocks, I think that use "supported and tested OS" for a specific software is not an efficient way to work. I wanna use the last version of ANSYS CFX in the last release of my linux distro in my case opensuse 12.1.

ghorrocks December 22, 2011 18:02

I knew I should not have posted an a thread about Linux support :)

It depends how you look at it. From the ANSYS point of view, they guarantee the software to work on some OS, and if new OS are released after that they do not guarantee it. But from a users point of view I can appreciate wanting to use the latest OS.

If you want a guarantee the software will work then you have to use the recommended OS.

If "it sort of looks like it works" is good enough and don't mind the occasional crash and funny work-around then stick whatever OS you like on there. But forget it if you want ANSYS support on it.

habo August 7, 2012 03:24


I got Ansys 14 Workbench (Design Modeler, Meshing, Fluent, CFD Post) running under openSUSE 12.1 and it works so far! First of all I am a beginner concerning Linux and Ansys.

My steps:

1) get the C-Script uname26.c - follow the readme
(for example use this link:

2) compile uname26.c to uname26

3) make the created file uname26 executable with the command: chmod a+x

4) start Workbench with uname26 and runwb2 together

like this (terminal):
<path of uname26>/uname26 <path of runwb2>/runwb2

I wrote a link in my .bashrc (you may put uname26 in the same folder like runwb2):
alias runwb3='<path of uname26>/uname26 <path of runwb2>/runwb2'

This procedure does not work with Ansys 13 (library problem!) I also got a virtual machine running with Opensuse 11.2 (not trivial to get it running properly) BUT it works fine with Ansys 13 (no kernel and no library problem). good luck.:D

All times are GMT -4. The time now is 15:16.