CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX/Ansys FSI Error (

Andrew.Coughtrie July 14, 2011 18:35

CFX/Ansys FSI Error
Hi all,

I was wondering if anyone had come across this error when running CFX with Ansys Multifield. The model is of an aortic heart valve in 2D.

The problem is that the solution can't get past the first coupled step and the Ansys solver fails with the following error:


One or more elements have become highly distorted. Excessive
distortion of elements is usually a symptom indicating the need for
corrective action elsewhere. Try ramping the load up instead of step
applying the load (KBC,1). You may need to improve your mesh to
obtain elements with better aspect ratios. Also consider the behavior
of materials, contact pairs, and/or constraint equations. If this
message appears in the first iteration of first substep, be sure to
run shape checking of elements
I've tried all that is suggested in the error text as well as reducing the time step size to see if the loads were being appliled too quickly. I'm not sure how to go about running shape checking when using coupling as the post processing is done using CFD post and not in Ansys Mechanical.

Any help would be greatly appreciated as this is driving me crazy, no matter what i do nothing seems to change.



stumpy July 15, 2011 09:58

The error means the Mechanical mesh distorted too much. Look at the forces sent from CFX (in the ANSYS.stdout) file and determine if they are reasonable. If not, look at the pressure on the wall in the CFX solution before it fails to figure out why. Since it fails in the first timestep you'll need to create monitor points for the force and displacement on the wall and enable "Monitor Coeff. Loop Convergence".

Andrew.Coughtrie July 19, 2011 16:35

2 Attachment(s)
Thanks for the suggestions Stumpy they have been helpful in determining what the issue is. The pressure at the Fluid-Solid interface increases at each coupling step of the first time step. The pressure oscillates until it reaches +/-1E+06[Pa]. I've been unable to work out what is causing the solution in CFX to act as it does, I've tried different boundary conditions and altering the solutions control settings but they don't seem to change anything. Any suggestions?

I've attached the CCL file and an image of how the pressure monitor is acting if it helps anyone in determining a course of action I might be able to pursue.



stumpy July 21, 2011 14:57

This shows an unstable interface solution. Search the CFX forum for the thread with the title "FSI and size of time-step". Look for the discussion on applying a source term coefficient to stabilize things.

All times are GMT -4. The time now is 10:58.