CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Interpolation of data on interfaces during initialization (

Chander July 18, 2011 06:10

Interpolation of data on interfaces during initialization
1 Attachment(s)

I am simulating a single phase conjugate heat transfer problem.
The issue I am facing is this:

When I restart a simulation and initialize it using a result file from a previous simulation (on the same mesh), I observe in the .out file that while data on all domains is interpolated from the previous result file to the current simulation, data from interfaces in the mesh in previous result file is not interpolated to the corresponding interfaces in the current simulation. The following message is printed in the .out file for each interface:

" There are no variables for interpolation from the source domain. |
| Please check the source file carefully. |

Now this does not seem to cause any problem with the simulation. However, I observe a sudden jump in the residual plot at the time of restart of the simulation (see attached residual plot).
1. Is this caused by the above mentioned lack of interpolation of data at interfaces?

2. Why the data is not being interpolated at the interfaces ?

3. How to solve this issue?

Josh July 22, 2011 02:58

Hi Chander -

I'm experiencing a similar problem. At first, I ran a 3D mesh simulation with periodic sides ("Sim2") from a converged 2D simulation ("Sim1") via mesh interpolation. I witnessed the jumps in the residuals, which are expected (despite the successful interpolation) since a new mesh is being used; however, I didn't receive your error message ("There are no variables for interpolation from the source domain..."), so I assumed everything was fine. After 1 timestep, I stopped the 3D simulation (Sim2), then ran a fresh simulation ("Sim3") with the results of Sim2 as the initial condition. Sim3 produced the error message and continued to run.

The periodicity seems to be causing the problems. Strangely, there is a different range of variables between Sim2 and Sim3. I'm not sure why.

I'm only outputting every 100 files. Does the GGI (periodic) interpolation require a .trn file?

For the record, here's the message that precedes the error:

Checking all source domain interfaces from the source file:
Target GGI is the same as domain interface "Periodic".

Start direct copying of variables from domain interface "Periodic".

Chander August 16, 2011 05:50

During the intervening time since I posted this issue here, I contacted Ansys support. They did not look into it and advised to use version 13. I am using version 12.1
Does anyone here know if this residual jump at the time of restart is a bug in version 12.1? The only problem with this jump is that my mesh is large and this jump at every restart increases the computational time. Is there a way (like some command) to avoid this? Secondly, CFX support said that this jump in residual will not lead to any accuracy issues . Does anyone here think otherwise?

I am running only steady state simulations and have no experience regarding whether you need a .trn file or not? If I understand you correctly, you are also facing this issue of non-interpolation of data on interfaces during a restart using the same mesh. What version of CFX are you using?

ghorrocks August 16, 2011 06:49

Looks like a simple restart issue. It is very common to get a residual jump on restarts, even when you are just continuing the same simulation. That is because there are lots of variables which are required to do a smooth restart which are not written to the results file (eg previous time step results for second order time stepping, domain coupling at GGI interfaces and many others).

So when you do a restart, especially when using more complex models (eg GGIs) I would not be surprised if the residuals jump. But a few iterations later it should converge back again and continue converging.

Chander August 16, 2011 07:18


Thanks Glenn for your reply. Yes, the residuals do come down quickly within 10-15 iterations after restart and convergence continues. Actually this becomes an issue because these 10-12 iterations consume some of the allowed time on on a shared cluster on which I do my simulations because the mesh is very large (>35 MILLION CELLS). Thats why I was looking for some way to avoid it by say some settings for restart.
However, as you said, it seems I will have to manage with this itself.

ghorrocks August 16, 2011 07:24

Why do you have to stop and restart? If you are adjusting the simulation parameters you can do that with edit run in progress - then you do not need to restart.

Chander August 16, 2011 07:29


Yes, I do the parameter adjustment like timescale etc. during the simulation itself...thanks to one of your post that I once read here :)
I have to restart if the simulation does not reach convergence before the time limit of the job queue expires on cluster. When this time limit is finished, CFX forms a result file and stops the simulation at that point. Then I use this result file to restart the simulation.

Josh August 16, 2011 12:15

My issue was that the new mesh did not align with the old one. Glenn solved it.

All times are GMT -4. The time now is 15:54.