CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX runtime error (

Tony12 September 13, 2011 18:25

CFX runtime error
I installed CFX just fine, but once the launcher is loaded and I try to run "CFX-Pre 11.0" a encounter a runtime error because of "CFX\bin\winnt\PreGui_ogl.exe". If I find the pregui_ogl.exe and try to run it from it's original location then I get an error that the "libCUEViewer.dll" cannot be found. The "libCUEViewer.dll" was installed in different folder within CFX. Why can't pregui_ogl.exe find libCUEViewer.dll?

This same problem occurs when running CFX-Post 11.0 even though the Solver opens fine.

Does anyone know why this is happening? I tried reinstalling CFX, but that didn't work. I installed ICEM about 2 years ago, but just recently tried to install CFX.


Lance September 14, 2011 02:26

I dont know anything about your problem, but you do realize that the current version of CFX is 13 (and soon 14)? Why bother with installing old versions? Things like your problem might have been fixed in the current release.

ghorrocks September 14, 2011 07:06

Firstly I agree with Lance, I would not waste your time with old versions.

But I suspect your problem is with the display driver. Firstly check that you have the correct and up to date drivers for your video card. If that does not fix it then start CFX-Pre using the -mesa option to use CPU rendering and it should work, but you won't get as good video performance.

Tony12 September 14, 2011 22:10

Lance - I've had this version on my HD for years so I figured that I would just use it. I'll probably just upgrade to the new release though.

Glen - (Sorry I didn't see your response to this same issue that someone else had in the past) while trying to run the mesa option I got an error that says the viewer_mesa.exe does not exist :/

PS, I think my first problem is the integrated graphics card that I'm using on my old laptop. That might have to change.

ghorrocks September 14, 2011 23:31

The CFX requirements state that you need to support openGL graphics (form memory). Integrated graphics, especially in old laptops, often does not support openGL - so time to upgrade the laptop.

But you might be able to run the mesa version. Are you sure you are doing the correct command line: "cfx5pre -graphics mesa" is what you are looking for I think.

All times are GMT -4. The time now is 18:16.