CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   ERROR #001100279 has occurred in subroutine ErrAction (

warlocklw February 15, 2012 06:00

ERROR #001100279 has occurred in subroutine ErrAction
| Memory Allocated for Run (Actual usage may be less) |

Data Type Kwords Words/Node Words/Elem Kbytes Bytes/Node

Real 167898.6 335.68 61.40 655854.0 1342.71
Integer 82789.1 165.52 30.28 323394.7 662.08
Character 2873.7 5.75 1.05 2806.3 5.75
Logical 65.0 0.13 0.02 253.9 0.52
Double 608.0 1.22 0.22 4750.0 9.72

| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| *** Run-time memory allocation error *** |
| Not enough free memory is currently available on the system. |
| Could not allocate requested memory - exiting! |
| |
| |
| |

Error above says that I don't have enough free memory, but I have 1.7GB RAM left, with 3.5GB harddisk space. Total nodes is 470k, so if the memory allocation factor is 1.0 should be sufficient. I tried restart computer, still get the error.

Before that I try run on the same model and same settings, and it can be runned, but now can't. Please help.

monkey1 February 15, 2012 06:20

The error is clear not enough memory.
And if I sum up the Kbytes listed above for your Problem I reach approximately 990 MB nearly 1 GB.
BUT you said you already ran that case once and it worked. And you say further that it was EXACTLY the same problem...did you run it on the same machine? or did you maybe change something?

Btw. how much RAM do you have installed on your machine?

ghorrocks February 15, 2012 06:29

Also your assessment that you have 1.7GB RAM available might mean it was asking for 1.8GB and it could not get it so it bombed out. Now is a good time to go to a parallel simulation.

warlocklw February 15, 2012 08:01

I run on the same machine with same settings. I have 1.7GB free RAM out of 3.2GB. I tried parallel master slave simulation, still have the same error. I added some more info and screenshots. Please help. Thanks.


DEFINE RUN SETTINGS - Default settings


monkey1 February 15, 2012 08:07

You have 2.6 Million Elements in your domain!!! I'm not sure if 1.7GB are enough to run the calculation, I would say no. Maybe on your first try when it worked you had more RAM free...
Can't you free up more memory by stopping all other programs running and retry? If it runs with more free ram then you have the solution to your problem.

warlocklw February 15, 2012 08:44

RAM should not the problem, since I tried run before and it utilizes only around 1GB and finish successfully.

monkey1 February 15, 2012 09:30

If this is so...then for my part...I got no clue what else it could be.

ghorrocks February 15, 2012 18:08

Are you running a 32 bit OS? Windows 32 bit is unlikely to be able to get slabs of memory like 1.7GB easily. It will work sometimes but not others.

warlocklw February 16, 2012 00:59

Well it kinda weird, yesterday I restart PC it still problem. Now overnight, I try run, and it can be runned smoothly. I don't know what the problem but it's now solved. Thanks all for answering this thread, really appreciate.

ghorrocks February 16, 2012 06:48

Again, do you have a 32 bit OS? Running big simulations on 32 bit systems can be hit and miss and sometimes you reboot and it works fine, and sometimes it is a problem.

warlocklw February 17, 2012 04:47

Yes 32 bit Windows XP. I have 4GB RAM though, but just 3.2GB usable.

ghorrocks February 17, 2012 05:15

Well that's it then. You are trying to run a model too large for a 32 bit OS. The maximum size model you can run in CFX on a 32 bit OS is theoretically 2GB, but in practise it is 1.3-1.7GB. So if your run is in the range 1.3-1.7GB it might sometimes work and sometimes not. You should either move to distributed parallel or use a 64 bit OS.

All times are GMT -4. The time now is 21:39.