CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Kinematic Diffusivity error (

lg88 March 17, 2012 04:37

Kinematic Diffusivity error
Hi everybody
These days I have been studying a case of electric arc. I set an additional Variable name EPOT whose equation is diffusive transport equation.And I set the kinematic diffusivity as "Electric Conductivity/density*factorPhi".Electric Conductivity is also an additional Variable whose equation is algebraic equation.And its value I have set as constant.But when I run the case I met the following error:

Error processing expression 'Kinematic Diffusivity'.
The expression is invalid because:
Electric Conductivity is not available for use in this term

Error processing expression: Kinematic Diffusivity = Electric Conductivity/density*factorPhi

What is the problem?How can I solve it?Thank you very much!


ghorrocks March 17, 2012 06:12

Electrical conductivity does not appear on the list of available variables. I would set the electrical conductivity to equal a CEL expression, then you can use this CEL expression in calculations like this one.

lg88 March 18, 2012 10:07

Thanks to Glenn.I have set the electrical conductivity to equal a CEL expression.And the error has been solved.But I met a new problem when I run the case.
| Reference Pressure Information |

Domain Group: corus

Pressure has not been set at any boundary conditions.
The pressure will be set to 0.00000E+00 at the following location:
Domain : corus
Node : 1 (equation 1)
Coordinates : ( 1.33974E-09, 0.00000E+00,-5.00000E-02).

Details of error:-
Error detected by routine MAKDIR


what does it mean?How can I solve it?Thank you very much!


ghorrocks March 18, 2012 17:52

This looks like two independant problems. The first one is you have not set any pressure level, so it guessed one. You should define a pressure level in your simulation somehow - either a pressure inlet or outlet, initial condition or something.

The second problem is regarding a gradient calculation of electrical potential. Not sure about this one, I would fix the first problem and see if this persists. But it probably is unrelated to the pressure level problem.

All times are GMT -4. The time now is 06:49.