CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   CFX Post: .trn files bunching? (

user_of_cfx March 20, 2012 08:13

CFX Post: .trn files bunching?

I ran a transient simulation that went on for about 1000 timesteps. Unfortunately the simulation timed out (I ran it on a cluster) about 300 timesteps before the end without a .res file but with the .trn files for each timestep up to that point saved as usual.

I decided to rerun the simulation starting from the last _full.trn file and collected the rest of the .trn files.

The question is, can I put the .trn files of the first part of the simulation in the folder of the second part and post process all the timesteps in one go? I need to extract time-averaged values so I need all the timesteps bunched in the same folder for my results.

I tried just copying the first-part trn files into the folder, but CFX Post will only read the second-part timesteps.

Any help that will save me from re-running the whole thing will be greatly appreciated. :)


Lance March 20, 2012 08:46

Coying all .trn files to the same folder should work, otherwise you can add the missing time steps in Post, under the timestep selector/add timesteps

Or load the first part (File/load results file), then do the same again but for the second part and check the "keep current cases loaded" and uncheck "open in new view"

user_of_cfx March 20, 2012 08:51

Hi Lance,

Thank you for your quick reply.

Adding timesteps in Post timestep selector did work, but putting them in the same folder initially did not. Do you know why that would be?

I am quite sure I did something similar with Ensight about a year ago and it worked, so I was quite surprised it didn't work with either Post or Ensight this time. Is there some setting I could change?

Many thanks again. Cheers, Christa

Lance March 20, 2012 08:59

hum, no, cant think of any setting you should change.
Why not use File/load results, select the last file, and check "load complete history as a single case".

user_of_cfx March 20, 2012 09:11

That worked too, thanks! :)

Any idea how to do the same thing in Ensight too? (if you are familiar with that pain of a software of course)

Ensight does not recognise .trn files, not even full.trn files, just .res, but I have no .res file from the first run because it timed out without creating one.

Lance March 20, 2012 09:15

I know some ensight, but have never used it with cfx. But I think you can rename the .trn file to .res instead - ensight should be able to read it then.

Or open the solver, tools, export results, export to ensight format.

user_of_cfx March 20, 2012 09:48

I can't find an export format in Post that is compatible with Ensight :(

The renaming of a full.trn to .res works just like a .res file, but it will still only load the 250 or so timesteps of the second part of the simulation. I have an inkling that the fact that some of the timesteps I saved as _full.trn confuses the Ensight into thinking that's where the simulations began or something. I will remove the fulls and see what happens.

I'll keep working on it, if I ever find a solution to it I will post it here.

Many thanks again! :)

Lance March 20, 2012 11:57


Originally Posted by user_of_cfx (Post 350420)
I can't find an export format in Post that is compatible with Ensight :(

Open the solver, not post.

user_of_cfx March 20, 2012 12:16

Oh sorry... still, in the export window only the post-timeout .trn files are available.

tobiasseidel December 3, 2015 05:48

This page describes well how to combine several .res files before importing in post:

All times are GMT -4. The time now is 22:22.