CFD Online Discussion Forums

CFD Online Discussion Forums (
-   enGrid (
-   -   engrid 1.4 installation problem on ubuntu 14.04 (

Neo by Matrix May 4, 2014 14:32

engrid 1.4 installation problem on ubuntu 14.04
I have followed the procedure described in this site:

but when I run from terminal the command at the step 7, engrid is not loaded, the terminal says so (translated in english :)) :

roberto@roberto-N56JRH:~/engrid/src$ ./start_engrid.bash
./start_engrid.bash: line 3: ./engrid: no such File or directory

I haven't still installed openfoam, but I don't believe that is this the problem.
I'm new forum user, I don't know if must open a new topic or use this one...

thanks a lot in advance.

wyldckat May 4, 2014 14:53

Greetings Roberto and welcome to the forum!

Sorry, I haven't managed to update enGrid's wiki page yet.

In the mean time, please follow the instructions on the following posts:
  1. post #4
  2. post #6
Best regards,

Neo by Matrix May 5, 2014 03:23

i have qt4:
"QMake version 2.01a
Using Qt version 4.8.6 in /usr/lib/x86_64-linux-gnu
I've follow also the post #6
I don't have any problem during the installation, but the program doesn't start, in /home/roberto/engrid/src/start_engrid.bash there are the following commands:
export LD_LIBRARY_PATH=./libengrid:./netgen_svn:$LD_LIBRARY_PATH

I'm not an expert of informatic field, however these are my tentatives:
roberto@roberto-N56JRH:~/engrid$ ./build.bash
usage :
roberto@roberto-N56JRH:~/engrid$ ./setup_ubuntu.bash
[sudo] password for roberto:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
qt4-dev-tools č gią alla versione pił recente.
libvtk5-qt4-dev č gią alla versione pił recente.
0 aggiornati, 0 installati, 0 da rimuovere e 7 non aggiornati.
You can start enGrid by typing 'engrid' from the command line (as non-root user) or with the help of the desktop menus.

roberto@roberto-N56JRH:~$ engrid
/home/roberto/engrid/run.bash: line 26: /home/roberto/engrid/src/engrid: no such File or directory

maybe the problem is more simple than it seems...

thanks for your fast reply !

Neo by Matrix May 8, 2014 12:18

nobody have an idea ? also in my dash appear the engrid icon but nothing happens when I click on it.


wyldckat May 8, 2014 14:52

Hi Roberto,

I haven't managed to look into this sooner, but I re-read your previous post and it seems you missed an important detail... when you ran:

it told you that a parameter was missing. You should have then run:

./build.bash ubuntu
Best regards,

Neo by Matrix May 9, 2014 04:28

the problem is always the same, nothing is changed, probably, I will install it on windows 8 :(...
thanks anyway Bruno

eaglemckenna June 17, 2014 13:24

I am now using Ubuntu 14.04, I have no problem with the installation up until the command to start the programme. After the engrid build when I run the command,

engrid will not run.
this is the terminal messages:
g++ -m64 -Wl,-O1 -o engrid release/main.o release/qrc_engrid.o -L/usr/lib/x86_64-linux-gnu -L/usr/X11R6/lib64 -lm -ltcl8.5 -L./libengrid -lengrid -L./netgen_svn -lng -L/usr/lib -lQVTK -lvtkCommon -lvtkDICOMParser -lvtkexoIIc -lvtkFiltering -lvtkftgl -lvtkGenericFiltering -lvtkGraphics -lvtkHybrid -lvtkImaging -lvtkIO -lvtkRendering -lvtksys -lvtkVolumeRendering -lvtkWidgets -lpthread -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore -lGL
/usr/bin/ld: cannot find -ltcl8.5
collect2: error: ld returned 1 exit status
make[2]: *** [engrid] Error 1
make[2]: Leaving directory `/home/gowain/engrid/src'
make[1]: *** [release] Error 2
make[1]: Leaving directory `/home/gowain/engrid/src'
make: *** [sub-engrid-pro-app-make_default-ordered] Error 2
gowain@gowain-Aspire-V5-122P:~/engrid/src$ ./start_engrid.bash
./start_engrid.bash: line 3: ./engrid: No such file or directory
gowain@gowain-Aspire-V5-122P:~/engrid/src$ ./build.bash ubuntu
bash: ./build.bash: No such file or directory

I am aware that another user had a similar problem and although I followed the threat I can not get to the bottom of this.

please help

eaglemckenna June 17, 2014 13:35

It seems there is a file missing; I am sure the solution is a simple one I just need a bit of guidance:

gowain@gowain-Aspire-V5-122P:~$ engrid
/home/gowain/engrid/run.bash: line 26: /home/gowain/engrid/src/engrid: No such file or directory

eaglemckenna June 17, 2014 13:38

line 24 to 26 in the gedit reads:
dir=`dirname $0`
export LD_LIBRARY_PATH=$dir/src/libengrid:$dir/src/netgen_svn:$LD_LIBRARY_PATH

p0kerus June 21, 2014 02:19

according to error tcl8.5 is not installed on your system ; please install it and report error again

eaglemckenna June 21, 2014 11:18

Thanks guys! Sorted. I can now use engrid for CFD simulations instead of using the tedious numerical blockmeshDict file approach for openfoam!
Looking forward to getting stuck into summer MSc project on aircraft passenger thermal comfort.
kind regards
I hope neo by matrix gets sorted too, if not. shoot me a message!

deviljho January 28, 2015 09:23

Hi eagle mckenna
can you tell me how do you finally solved the problem?
i have the same problem... :(

eaglemckenna February 1, 2015 21:59

OK, you need to install the following:
download the tar from this link:
and as root move the corresponding files to:
let me know if this works!

eaglemckenna February 1, 2015 23:29

solution revisited
i have had to install engrid on my home machine: the solution to the error is tedious, you may not need to do the above: download the following via a mirror link:
unzip it
as root within terminal move the files to their corresponding directories.
take care.
let me know how it goes.

santoo_cfd January 29, 2016 09:06

I am not sure whether you were able to solve this issue or not. The error during Make is due to missing tcl library as shown below.

/usr/bin/ld: cannot find -ltcl8.5
collect2: error: ld returned 1 exit status
make[2]: *** [engrid] Error 1
make[2]: Leaving directory `/home/skva/engrid/engrid/src'
make[1]: *** [release] Error 2
make[1]: Leaving directory `/home/skva/engrid/engrid/src'
make: *** [sub-engrid-pro-app-make_default-ordered] Error 2

Simple fix to this to install this library seperately which can be done by executing

sudo apt-get install tcl8.5
After this, just re run

source build.bash ubuntu

All times are GMT -4. The time now is 04:31.