CFD Online Discussion Forums

CFD Online Discussion Forums (
-   enGrid (
-   -   engrid GUI doesn't appear (

almeidatg June 10, 2015 12:32

engrid GUI doesn't appear
Hi, enGrid Gurus.

I have a cluster running Centos 5, and I have followed the instructions to build Qt 4.8.6, VTK 5.10 and enGrid 1.4 (all from source).

I know my machine is old, but I was wondering if anyone had run into a problem where everything appears to build correctly, but when trying to execute the engrid executable (after setting the LD_LIBRARY_PATHS), nothing happens. It just hangs (until ctrl-C). No errors/warnings.

Thanks so much for any help you can offer.



wyldckat June 10, 2015 15:48

Quick questions:
  1. Does any other GUI built from source code work as intended in your installation? For example ParaView?
  2. What does the following command give you?

    ldd engrid

    ldd $(which engrid)
    The first one assumes you run the command in the same folder where enGrid is installed; the second one searches the paths in "PATH".

almeidatg June 10, 2015 16:02

Thanks for the quick response, Bruno. I appreciate it.

I have installed ParaView from source, and the GUI worked.

Here is the output you requested:


ldd engrid => /usr/lib/ (0x00002b78e034c000) => /share/disk2/thomas.almeida/CODES/enGrid/engrid-release-1.4-j4/src/libengrid/ (0x00002b78e0666000) => /share/disk2/thomas.almeida/CODES/enGrid/engrid-release-1.4-j4/src/netgen_svn/ (0x00002b78e0c42000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e110b000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e1371000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e18ad000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e1ac7000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e1d0c000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e2318000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e2523000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e2749000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e30b5000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e3507000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e3ab9000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e41aa000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e482b000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e4a66000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e51f1000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e55ab000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e57ef000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e5af2000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e67d9000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e6b1f000) => /lib64/ (0x000000301f000000) => /usr/lib64/nvidia/ (0x0000003f29c00000) => /share/apps/gcc-4.7.2/rtf/lib64/ (0x00002b78e70a3000) => /lib64/ (0x000000301e800000) => /share/apps/gcc-4.7.2/rtf/lib64/ (0x00002b78e73ac000) => /lib64/ (0x000000301e400000) => /lib64/ (0x000000301ec00000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e75c2000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e90ee000) => /share/disk2/thomas.almeida/CODES/Qt-4.8.6-j4/lib/ (0x00002b78e9737000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e9978000) => /usr/lib64/ (0x0000003026400000) => /usr/lib64/ (0x0000003024400000) => /usr/lib64/ (0x0000003020400000) => /usr/lib64/ (0x0000003021c00000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e9bf8000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78e9ff1000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ea395000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ea694000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ea8c2000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ead61000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78eaf76000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78eb1fe000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78eb436000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78eb657000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78eb864000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ebafe000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ebda2000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ebfca000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ec1fa000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ec459000) => /usr/lib64/ (0x0000003030a00000) => /usr/lib64/ (0x0000003022800000) => /usr/lib64/ (0x0000003024000000) => /usr/lib64/ (0x0000003025000000) => /lib64/ (0x0000003025c00000) => /lib64/ (0x0000003020800000) => /usr/lib64/ (0x0000003024c00000) => /usr/local/lib/ (0x00002b78ec684000) => /lib64/ (0x0000003021400000) => /lib64/ (0x000000301f800000)
        /lib64/ (0x000000301e000000) => /usr/lib64/nvidia/ (0x0000003f29200000) => /usr/lib64/nvidia/tls/ (0x0000003f29000000) => /usr/lib64/ (0x0000003021000000) => /usr/lib64/ (0x0000003020c00000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ec89c000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ecc2d000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ece52000) => /share/disk2/thomas.almeida/CODES/VTK-5.10-j4/lib/vtk-5.10/ (0x00002b78ed06c000) => /lib64/ (0x0000003022c00000)

wyldckat June 15, 2015 15:46

Hi Thomas,

Sorry, I wasn't able to answer sooner, but I have thought about this in the meantime.

The best I can think of is that since you are using a cluster, there are more possible ways of you to access it's desktop interface:
  1. Directly connected with a monitor to the main machine on the cluster.
  2. Connected via VNC.
  3. Connected via "ssh -X".
  4. Connected via some NX protocol (it's an X-VNC-hybrid protocol).
If the problem occurs with the #1 connection... then I have no idea what's going on :( Perhaps the window pops up behind other windows?

If the problem occurs with either one of the other solutions, then it's odd that it doesn't complain with an error message. Nonetheless, this would be very likely due to the fact that the ldd output points out that it connects directly to the NVidia OpenGL libraries:
Code: => /usr/lib64/nvidia/ (0x0000003f29200000) => /usr/lib64/nvidia/tls/ (0x0000003f29000000)

Without at least some more details on how you are accessing the desktop interface on the cluster, I can't remember any more possible issues... since most of them that come to mind depend on actual error messages.

I do have a blog post with a collection of threads/posts for when problems occur with ParaView: Related issues to ParaView with OpenFOAM - Fixes and solutions - most of them are applicable to enGrid as well, given that the library dependency stack is very similar (VTK, Qt and OpenGL ;)).

Best regards,

almeidatg June 15, 2015 16:08

Dear Bruno,

Thanks once again for taking the time...

I think it must have something to do with the Nvidia library. I have had some issues with the OpenGL renderer crashing my x-session while using Matlab on this system. I traced it down to the Nvidia drivers, but had a terrible time upgrading them. My work-around for the Matlab issue was to force Matlab to use the 'painters' renderer in lieu of the OpenGL renderer.

So far, I have tried to use engird via VNC and ssh -X; I'll try running it from the box itself (direct connection) and see what happens.

I'll post what I find in the near future.



All times are GMT -4. The time now is 12:50.