CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > enGrid

Build the NETGEN library fails

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 24, 2017, 10:02
Default Build the NETGEN library fails
  #1
Member
 
Fynn
Join Date: Feb 2016
Posts: 32
Rep Power: 3
PanPeter is on a distinguished road
Hi,

I am trying to install engrid but when it comes to installing the netgen library, the download link for the sources fails:

Code:
 scripts/build-nglib.sh
--2017-01-24 14:56:25--  http://engits.eu/files/netgen-4.9.13.zip
Resolving engits.eu (engits.eu)... 178.238.231.152
Connecting to engits.eu (engits.eu)|178.238.231.152|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-01-24 14:56:25 ERROR 404: Not Found.

unzip:  cannot find or open netgen-4.9.13.zip, netgen-4.9.13.zip.zip or netgen-4.9.13.zip.ZIP.
mv: cannot stat ‘netgen-4.9.13’: No such file or directory
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur netgen-4.9.13/libsrc/general/ngexception.hpp netgen/libsrc/general/ngexception.hpp
|--- netgen-4.9.13/libsrc/general/ngexception.hpp	Mon Aug 10 13:40:52 2009
|+++ netgen/libsrc/general/ngexception.hpp	Wed Apr 13 10:57:39 2011
--------------------------
Has anybody know how to solve this issue?
Thanks
PanPeter is offline   Reply With Quote

Old   January 24, 2017, 11:45
Default
  #2
Member
 
Fynn
Join Date: Feb 2016
Posts: 32
Rep Power: 3
PanPeter is on a distinguished road
So, netgen can be downloaded from sourceforge, https://sourceforge.net/projects/netgen-mesher/, and the installation can be continued following the steps in the script build-nglib.sh. But that only worked with the same version of netgen, that is mentioned in the script, which is not the most recent one.

Later during the installation, the linking failed because the library ltcl8.5 couldn't be found but I found the solution to that problem here: https://ubuntuforums.org/showthread.php?t=2219242
PanPeter is offline   Reply With Quote

Reply

Tags
netgen installation

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Building from Source on Windows using Cygwin64 ericthefatguy SU2 2 May 12, 2015 18:23
decomposePar is missing a library whk1992 OpenFOAM Pre-Processing 8 March 7, 2015 08:53
Netgen mesh of a geometry with a cut fails kontra Open Source Meshers: Gmsh, Netgen, CGNS, ... 0 November 28, 2013 10:46
OpenFOAM141dev linking error on IBM AIX 52 matthias OpenFOAM Installation 24 April 28, 2008 15:49
Canbt build library on amd64 kar OpenFOAM Running, Solving & CFD 2 April 14, 2008 07:13


All times are GMT -4. The time now is 13:40.