CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > EnSight

Rigid body motion on transient fluent mrf

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By kevincolburn

Reply
 
LinkBack Thread Tools Display Modes
Old   September 1, 2014, 09:54
Default Rigid body motion on transient fluent mrf
  #1
Senior Member
 
ghost82's Avatar
 
Daniele
Join Date: Oct 2010
Location: Italy
Posts: 993
Rep Power: 17
ghost82 will become famous soon enough
Hi!
I'm just testing the Ensight software and first impressions are very positive.
I like the rigid body motion option to rotate mrf cases.

I tried the rigid body motion setup on a single couple of cas/dat (fluent) mrf and it works well.

I cannot get rigid body motion to work with a mrf transient solution (I simulated a stirred tank with vof in fluent, a transient simulation to explore the vortex formation).

What I did is:
1- Export from fluent solutions to ensight gold format: this generated files: 1 .encas, 1 .geo, 1 .vel and several sclxxx (for the variables I chosed)
2- Start Ensight and open the .encas file (the ensight window shows a transient solution made of 14 time steps, 0 to 13); I can create the isosurface to animate the free surface morphology with no problem
3- Select the impeller zone, click on user tools, visualize, rigid body motion: set the center of rotation, axis direction, set rpm to 120, 14 time steps and flow time to 1,3 s (which is the end of the simulation) and chose the existing .encas file
4- This generate _rbm.case, _rbm.eet and _rbm.erb files in the working directory

Instead of the popup window which should ask to reload the case with rbm enable nothing happens
If I try to load the new generated _rbm.case an error shows unable to load data.

So my question is: how to correctly setup the rigid body motion for a transient mrf simulation?

Thank you!
ghost82 is offline   Reply With Quote

Old   September 2, 2014, 08:30
Default
  #2
Member
 
kevincolburn's Avatar
 
Kevin Colburn
Join Date: Mar 2009
Posts: 95
Rep Power: 9
kevincolburn is on a distinguished road
Looks like you did all as you should. It sounds like an error in the RBM Setup tool. I suspect this has to do with the handling of the timesets already in the original .encas file (which you did not have in the steady state which worked okay). If you could send me a private email with just your original .encas file, and the new .encas file (which does not work), I think it should be an easy fix (just need to allow for the logic of the timesets already in the original .encas file.

-Kevin
ghost82 likes this.
__________________
Kevin Colburn
Computational Engineering International, Inc.
www.ceisoftware.com
kevin@ceisoftware.com
kevincolburn is offline   Reply With Quote

Old   September 2, 2014, 09:05
Default
  #3
Senior Member
 
ghost82's Avatar
 
Daniele
Join Date: Oct 2010
Location: Italy
Posts: 993
Rep Power: 17
ghost82 will become famous soon enough
Thans for fast reply.
I will write as soon as possible with attached files.
Yes, I agree with you, I thought about a time step conflicting problem.
ghost82 is offline   Reply With Quote

Old   September 3, 2014, 04:05
Default
  #4
Senior Member
 
ghost82's Avatar
 
Daniele
Join Date: Oct 2010
Location: Italy
Posts: 993
Rep Power: 17
ghost82 will become famous soon enough
Just for reference if someone else has same problems.
The error was in the eet file.
Number of time steps must be the same as the transient fluent simulation (which in my case was 14).
However, setting the same number of time steps (14) in the rmb gui in ensight did not work, the eet was created with 37 time steps (bug?).
The solution is to manually edit the eet file, so to set the right number of time steps.
Thanks to Kevin for fast reply and solution to the problem.

I think he (and the team) is working on the bugfix (if any).
ghost82 is offline   Reply With Quote

Old   September 6, 2014, 11:24
Default
  #5
Senior Member
 
ghost82's Avatar
 
Daniele
Join Date: Oct 2010
Location: Italy
Posts: 993
Rep Power: 17
ghost82 will become famous soon enough
I noticed that the eet file is always created with a number of time steps of +23 in respect of what is specified by default (which is the correct value) in the rbm gui.
Maybe this is usefull for the bug fix.

EDIT:
Bug is fixed and it will be corrected in version 10.1.1(d).

Last edited by ghost82; September 14, 2014 at 11:34.
ghost82 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The fluent stopped and errors with "Emergency: received SIGHUP signal" yuyuxuan FLUENT 0 December 3, 2013 23:56
Rigid body motion error when restarting a terminated FSI simulation lingdeer ANSYS 1 May 19, 2013 01:40
Rigid body motion + Boundary Layer Manoj Kumar FLUENT 4 May 26, 2012 10:34
simple rigid body motion UDF Dan FLUENT 0 January 11, 2006 06:48
rigid body motion antonello FLUENT 3 July 28, 2004 03:25


All times are GMT -4. The time now is 07:02.