CFD Online Discussion Forums

CFD Online Discussion Forums (
-   EnSight (
-   -   Ensight gold transient data reading error (

cfd_addict April 22, 2009 09:52

Ensight gold transient data reading error
Hi everybody

I performed a transient calculation using Fluent 6.3 and exported ensight gold data every n time steps.
The point is that Ensight can only read the first three solutions (corresponding to the first three time steps). For every solution from the 4th time step to the end, Ensight displays the following error message:
" Unidentifiable line read in variable file:
toto_****.scl1 " and no field is loaded (only the geometry is).

I thought it came from the solution file itself but there is no problem when loading the solution with paraview. Why the export would have changed during the calculation and how can I fix this?
Has anyone already had a problem like this before? :confused:

Thx for your help!

kevincolburn April 24, 2009 09:31

Ensight gold transient data reading error
I'll try to help through this problem that you are having... What version of EnSight are you using? Is the Fluent transient job still running, or has it completed? I 've used Fluent + EnSight quite a bit, and have not come across this specific problem.


cfd_addict April 24, 2009 09:43

I'm using Ensight 8.2.
My job is completed and my problem is that I only have ensight gold files and no intermediate solution .dat on this calculation. As long as ensight can not read the files, I can not visualize intermediate results (except with paraview).

kevincolburn April 24, 2009 16:23

Ensight gold transient data reading error

Ok. Thanks for that information.
1. Did you attempt to view the results while Fluent was solving the transient (even if later attempts are now that Fluent solver is complete). If you try to view the results while Fluent is still solving, Fluent ends up corrupting the files, resulting in unusable/no longer viewable files.
2. If not, could you send me the .encas file, the .geo, and one of the variable files that it fails to read?
3. The other thing that you can do is run "ens_checker8". This runs diagnostics on the EnSight files, and usually gives a clearer indication of the source or the error/correction.
-kevin (

cfd_addict April 27, 2009 04:18

Thanks for your help
I didn't know about "ens_checker" existence and it's true it can be useful. I've just tried on my test case and I get this error message:

===> Problem:
Looking for one of the following valid line types:
coordinates (unstructured coordinates)
element type (unstructured types, any of the following:
point tria6 tetra10 penta15 nfaced
bar2 quad4 pyramid5 hexa8
bar3 quad8 pyramid13 hexa20
tria3 tetra4 penta6 nsided
g_point g_tria6 g_tetra10 g_penta15
g_bar2 g_quad4 g_pyramid5 g_hexa8
g_bar3 g_quad8 g_pyramid13 g_hexa20
g_tria3 g_tetra4 g_penta6 g_nsided g_nfaced
block (structured block)
part (the next part)
but found the following:


I think variable files are corrupted, although I didn't try to view results while Fluent was computing. The only thing I could have done is to copy visualization files on another disk while fluent running. Do you think it is enough to make Fluent corrupt files? the surprising thing is that for 2 calculations this error occurs from the 4th file.

kevincolburn April 27, 2009 09:43

Ensight gold transient data reading error

Are you trying to load the "copy" version of the files, or the originals? While fluent is solving, the EnSight files are open, and continually being appended to. So, I could see that trying to copy these files (which have not been closed/finished properly) would cause the "copied" version of the files to be corrupt. I would be kind of surprised if this action caused a problem to the original files.
Your datafile is certainly corrupt with junk characters. (did the disk or partition become full during the run... causing the file corruption?)

-kevin (

cfd_addict April 28, 2009 05:04

I'm not working on the version of the files I've copied while the calculation was running but on some other "copied versions". Actually, files were created during the calculation on a cluster machine and were all copied at the end of the calculation on my working space.
=> Some files that I didn't copy while the calculation but that have finally been copied at the end of the calculation show the same error as presented above.
Final copying process is a classic rcp fonction. Could it corrupt datafiles?
By the way there was no problem of free space on the disk during the run.

MuratSuer December 19, 2012 14:44

I faced same problem. Solution: you use only one star (*) instead of 4 star to define the iteration number. It works try it.


All times are GMT -4. The time now is 08:51.