CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > FloEFD, FloWorks & FloTHERM

FloEFD Copy Component Instance

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 12, 2018, 08:40
Default FloEFD Copy Component Instance
  #1
New Member
 
Cameron
Join Date: Mar 2018
Posts: 10
Rep Power: 3
cattewell is on a distinguished road
Hello,

I'm trying to use Catia V5 to perform a FloEFD simulation of a car headlamp which contains many LEDs. I have defined one of the LEDs and I am now looking to define the others. Is there a way to copy this to all the other identical LEDs without setting each one up individually? I believe this can be done using the copy to component instance feature but it doesn't seem to be working.

When attempting to use the copy to component instance feature, I right click on LED1 (the one I set up), then go LED 1 Object -> Copy to Component Instance. I then get a dialog box with LED 1 as the feature to copy, and then a long list of the LEDs in the Target Component box. However when I press OK nothing appears to happen. Am I doing this wrong? Is there another way to do this?

Many thanks

Last edited by cattewell; September 13, 2018 at 05:07.
cattewell is offline   Reply With Quote

Old   September 13, 2018, 14:00
Default
  #2
Senior Member
 
Boris Marovic
Join Date: Jul 2009
Posts: 584
Rep Power: 18
Boris_M will become famous soon enough
Hi Cameron,

the copy to component instances only works if it is the same part built multiple times into the assembly. So the exact same part file, not LED1.catpart and LED2.catpart etc. It needs to be the same part.
FloEFD will search for those repeated use of parts and applies the boundary condition then on the same features such as surfaces etc. So make sure if you use cubes, that the one cube doesn't have the face to the PCB and the other to the air if that surface has assigned a boundary condition. They should all be oriented the same way.

The way you describe it, it should be correctly modeled. Usually, if you say ok, it starts creating the boundary condition for every single LED.
What version are you using?
Maybe there is a bug in an older version you might be using.

Regards,
Boris
Boris_M is offline   Reply With Quote

Old   September 14, 2018, 04:36
Default
  #3
New Member
 
Cameron
Join Date: Mar 2018
Posts: 10
Rep Power: 3
cattewell is on a distinguished road
Hi Boris,

Yes, the LEDs are all identical to each other so I don't think this can be the problem. We are using V15, do you know how we can update this?

Thanks again,

Cameron
cattewell is offline   Reply With Quote

Old   September 14, 2018, 10:38
Default
  #4
Senior Member
 
Boris Marovic
Join Date: Jul 2009
Posts: 584
Rep Power: 18
Boris_M will become famous soon enough
The latest version is V17.3.
If your license supports anything newer, you can log in to the Mentor Support Center website and download the latest or the supported version there.

Regards,
Boris
Boris_M is offline   Reply With Quote

Reply

Tags
assign led, catia v5, copy component instance, floefd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error running openfoam in parallel fede32 OpenFOAM Programming & Development 5 October 4, 2018 17:38
Multiphase flow - incorrect velocity on inlet Mike_Tom CFX 6 September 29, 2016 02:27
Momentum source coefficient, cylindrical coordinates, circumferential component? polakse CFX 15 January 18, 2016 03:40
FloEFD fluid volume not recognized Edd FloEFD, FloWorks & FloTHERM 5 February 9, 2011 00:28
UDF component in Cyliderical Velocity? Hongchan Kim FLUENT 3 April 24, 2001 13:20


All times are GMT -4. The time now is 15:01.