CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FloEFD, FloWorks & FloTHERM (
-   -   Missing heat source (

Phil June 9, 2008 09:44

Missing heat source
Hey all,

Having an issue with running thermals on Floworks. I'm trying to run multiple instances on our server, testing out different heat sinks. However, if I try running more than one, the second - which is using exactly the same parts and mates as the first except for the switched out heat sink component - says that it cannot find the bodies associated with my heat sources. The components of the heat source are definitely in the assembly, but even after deselecting and selecting, Floworks refuses to acknowledge their existence.

Fine, I say. I just make copies of the heat sources and assemblies such that each assembly has its own separate file for the component with the heat source. Except when I try to run more than one at a time, I again get one of the assemblies denying that its heat sources exist. Does anyone have any idea of where this is coming from?

Bill McEachern June 9, 2008 10:00

Re: Missing heat source
Phil, Are you using the batch solve? Do you have a separate configurations for each analysis run? Did you clone the original project to make the different cases?

Phil June 9, 2008 10:20

Re: Missing heat source
No, the assemblies are all separate files, not different configurations. I just copied the original in Windows Explorer a few times, did the same thing for the heat sinks and heat sources, then switched out the copied parts in the copied assemblies. To run them, I open multiple instances of Solidworks, load a different assembly into each and have them solve.

Is this something different from cloning?

Phil June 9, 2008 11:24

Re: Missing heat source
Ok, I think I may have resolved the problem on my own by suppressing, then unsuppressing the heat sources.

Phil June 9, 2008 16:12

Re: Missing heat source
I retract my earlier comment. Multiple instances cause the problem to occur again. I tried a batch run, but again, after the first run, error messages showing missing heat sources appeared again. Anyone familiar with any of this?

Bill McEachern June 10, 2008 23:56

Re: Missing heat source
Hi Phil, You can avoid all this by not making multiple instances and copies. Just set up a study, get it all set to go. Then clone (RMB a the top of the Floworks tree and pick clone study) the study, make your changes to the geometry then set up up the the new Bc's, sources, goals what have you and keep doing this till you have all your jobs ready to go. Of course you can test just one out first to make sure it is working as intended then you can use the computed results as starting condition for hte alternate studies whiich helps thing solve quicker. Then use the batch solver to run them all. If you run multiple instances of SWX using the same parts in memroy then trouble will ensue. If you keep it all in the same instance it works fine in my experience. Hope that helps,

Phil June 12, 2008 10:03

Re: Missing heat source

This looks promising. However, I'm getting a new error keeping me from replacing the heatsink file with a different file in the cloned configuration: CoInitialize has not been called. Google search is showing nothing on this, do you know where it may be?

Thanks for your help so far.

Bill McEachern June 12, 2008 19:34

Re: Missing heat source
That might be a bug in SWX. I have had it before but I haven't had it for awhile. Could be an installation error. You really want to be running SP3.1 - it works pretty well. Did this happen when you tried to put the part in the assembly? If so I think if you shut every thing down, open up swx, uncheck the floworks add-in, then assemble the part in the assembly, save the assembly and then turn on floworks it might solve the problem. This will probably work if you are using SP2.

If the heat sink is a different part for any other heat sink you just need to suppress it in all the other configs and unsupress it in the one you want. Should all work fine.

Ruben van Ruijven June 18, 2008 10:32

Re: Missing heat source
Could it be that the SW assably is messed up. If you open the same assambly multiple times using the part with similar names multiple times, things can get messed up internally within the SW assambly....

Best to get a clean EFD/Floworks model that works correctly, than just clone it for varation analysis.

Bill McEachern June 19, 2008 10:33

Re: Missing heat source
I totally disagree. This works bullet proof if you know SWX and Floworks. Good luck

All times are GMT -4. The time now is 06:05.