CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLOW-3D (
-   -   running flow-3d in command line (linux) (

dieter April 19, 2010 09:48

running flow-3d in command line (linux)
I suffered a small problem when trying to run flow-3d from the command line in linux. I use the custom double solver with a user definable namelist (usrdat). When trying to preprocess the prepin file, the preprocessing process gets stuck (a number 1 is shown in the command line).
However, when running the same input file in the gui, the preprocessing is completed in a normal way. Anyone has a clue how to solve this?

thanks in advance


dieter April 20, 2010 08:22

The problem can be solved by explicitly defining the solver version, in this case use:

export F3D_VERSION=prehyd

MuxaB May 2, 2010 16:11

Thank you, Dieter June 12, 2016 04:14


Originally Posted by MuxaB (Post 257221)
Thank you, Dieter

I am also find this problem. I want to know whether the probelm is solved? and how to solve.

MuxaB June 13, 2016 10:38

There is really no problem. There are two places where the solver resides in a standard FLOW-3D installation: $F3D_HOME\prehyd\hydr3d and $F3D_HOME\double\hydr3d. The prehyd folder contains the user customized executable.

The environment variable F3D_VERSION points to either double or prehyd, with the default being double. You either need to set F3D_HOME=prehyd in the command windows you are working in, or set it in the global setting script, e.g., .cshrc, in which case it will be set automatically every time you open a command window. July 31, 2016 21:56


because of the version difference, the some parameters in prepin file is changed.

change them and resubmit.

All times are GMT -4. The time now is 05:47.