CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > FLUENT > Fluent UDF and Scheme Programming

Problems with RP_Get_Input_Parameter

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By jortega

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 28, 2015, 12:31
Default Problems with RP_Get_Input_Parameter
  #1
New Member
 
Joaquin
Join Date: Mar 2009
Location: Málaga, Andalusia, Spain
Posts: 6
Rep Power: 14
jortega is on a distinguished road
Dear fluent-users,

I am using Ansys-fluent 15.0.0 to carry out a parametric simulation with design explorer and surface response. I need to pass two of the parameters to an UDF and I define them as "Use in UDF" in the parameter window. Then, in the UDF file I read them by


real k=RP_Get_Input_Parameter("real-1");


This works, and the value of the parameter can be read in the UDF.

But when I define a second parameter and try to read it too by


real n=RP_Get_Input_Parameter("real-2");


after running the udf, fluent says


Error: received a fatal signal (Segmentation fault).

Did anybody have this problem before?
If so, or you have any idea to solve it, please, let me know it.

Thanks in advance.

Regards.
jortega is offline   Reply With Quote

Old   February 3, 2015, 02:53
Default SOLVED: Problems with RP_Get_Input_Parameter
  #2
New Member
 
Joaquin
Join Date: Mar 2009
Location: Málaga, Andalusia, Spain
Posts: 6
Rep Power: 14
jortega is on a distinguished road
Thanks to this page:

http://www.computationalfluiddynamic...sys-workbench/


I finally solved my problem.




Quote:
Originally Posted by jortega View Post
Dear fluent-users,

I am using Ansys-fluent 15.0.0 to carry out a parametric simulation with design explorer and surface response. I need to pass two of the parameters to an UDF and I define them as "Use in UDF" in the parameter window. Then, in the UDF file I read them by


real k=RP_Get_Input_Parameter("real-1");


This works, and the value of the parameter can be read in the UDF.

But when I define a second parameter and try to read it too by


real n=RP_Get_Input_Parameter("real-2");


after running the udf, fluent says


Error: received a fatal signal (Segmentation fault).

Did anybody have this problem before?
If so, or you have any idea to solve it, please, let me know it.

Thanks in advance.

Regards.
jortega is offline   Reply With Quote

Old   February 16, 2015, 12:39
Default RP_Get_Input_Parameter not working
  #3
New Member
 
engineer
Join Date: Feb 2015
Posts: 1
Rep Power: 0
MSNJ3 is on a distinguished road
Hi jortega,

I have the same problem. Would you please tell us about the step-by-step process of how you solved it. I couldn't get the procedure in the link to work.

Also I wanted to know if you have contacted Ansys tech support about this?

Thanks,
MSNJ3
MSNJ3 is offline   Reply With Quote

Old   February 27, 2015, 02:43
Default
  #4
New Member
 
Joaquin
Join Date: Mar 2009
Location: Málaga, Andalusia, Spain
Posts: 6
Rep Power: 14
jortega is on a distinguished road
Hi MSNJ3,

I just followed the steps given in the link and it worked.

I didn't contact with ANSYS tech. support. Maybe you should do it. If so, please, let us know what they say.

Regards.
myaghoobi2 likes this.
jortega is offline   Reply With Quote

Old   September 5, 2017, 02:30
Default
  #5
New Member
 
mohammad
Join Date: May 2016
Location: Tehran
Posts: 17
Rep Power: 7
myaghoobi2 is on a distinguished road
Hi all This will work for using parameter in UDF just do what he says:
https://www.cfd-online.com/Forums/members/jortega.html
myaghoobi2 is offline   Reply With Quote

Reply

Tags
design explorer, udf parameter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Problems with coedge curves and surfaces tommymoose ANSYS Meshing & Geometry 6 December 1, 2020 11:12
[mesh manipulation] Problems with rotational cyclic boundaries TReviol OpenFOAM Meshing & Mesh Conversion 8 July 11, 2014 03:45
[ICEM] Flow channel meshing problems StefanG ANSYS Meshing & Geometry 19 May 15, 2012 06:44
Two-phase air water flow problems by activating Wall Lubrication Force challenger85 CFX 5 November 5, 2009 05:44
Help required to solve Hydraulic related problems aero CFX 0 October 30, 2006 11:00


All times are GMT -4. The time now is 20:08.