CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Fluent UDF and Scheme Programming (
-   -   load libudf problem (

alfred February 26, 2007 15:18

load libudf problem
Hello there,

I am a beginner to fluent. I am trying to define udf through compiled function and then load libudf. It seems fine after I click "build", but I always get error message as below when I click "load"... (I am using windows version, VC is installed).

1 file(s) copied. (system "copy C:\Fluent.Inc\fluent6.2.16\src\makefile_nt.udf libudf\ntx86\2d\makefile") 1 file(s) copied. 0 (chdir "libudf")() (chdir "ntx86\2d")()

Done. "c:/phdwork/fluentcases"

Opening library "libudf"... Error: open_udf_library: The system cannot find the file specified.

Error Object: ()

thank you in advance for any help or comments...

Shanti February 26, 2007 19:05

Re: load libudf problem

Do you have nmake.exe installed on your computer? Also try putting the libudf folder in your working directory of FLUENT. I am not sure if its causing that. But it helped me.



Sangeeta March 7, 2007 08:54

Re: load libudf problem
I too am facing the same problem. and i d'nt have nmake.exe installed in my PC. How could i get it? I have libudf folder in my working directory.

Thanks in advance.

Ravi Bharihoke March 11, 2007 10:09

Re: load libudf problem
Hi Alfred,

I am facing exactly the same problem as you mentioned.

Can you please tell in details about what you did for compiling udf. If you wish you can mail to ...

sorry i am sounding little impatient but am in urgent need as i have very less time left to complete my project.

Ravi IIT Kharagpur

Sangeeta March 11, 2007 12:06

Re: load libudf problem
For compiling i add the source file and then click on it and say build.then when i say load i get the above error.

But i was told by fluent support to go to Dos prompt. GO the the directory where ur source and c files are there and say fluent 2d/3d and the enter.

So try this and chck. Each time u compile erase the libuf folder created when u earlier compiler

ravi March 11, 2007 19:55

Re: load libudf problem
Hi Sangeeta,

Thank you for your reply.

I tried it the way you said, but am still getting the same error " The system cannot find the file specified".

Just read this once 1. I go to cmd and go to the folder where my udf and case files are there 2. I type Fluent 2d there. 3. Then Fluent opens, i select my case file. 4. I go to define udf option add my source file "udf_name.c" Then i build the udf n then i load my udf.

Isn't it the same procedure as earlier?... Did it work for you?....

In anticipation of your reply,

Regards, Ravi

Sangeeta March 13, 2007 13:02

Re: load libudf problem
Sorry, it didnot even work for me. i am trying to get it solved and if i did it i wll surely let u know. if u solve it before me then plz let me know.


Tania March 14, 2007 07:00

Re: load libudf problem

I had the same problem when I run Fluent in windows. But then I installed VisualC++, everything worked. It seems that you need to have a compiler installed in the computer. This is how I solved my problem.

Here are the steps, I do to run an Udf file.

1- put the udf file in my case directory.

2- Go to Define>user-defined Functions>Compiled> There you should first add the udf file.

3- Click on BUILD

4- Click on LOAD should work.


Sangeeta March 14, 2007 10:58

Re: load libudf problem
I have visual C++ loaded on my pc but still it doent work


Sangeeta March 14, 2007 11:10

Re: load libudf problem
i have DevCPP compiler but it does not compile yet

Tania March 15, 2007 02:43

Re: load libudf problem
Sangeeta, It seems that you had visual c++ installed before Fluent. If I were you I'll uninstall Visual C++ and Install it again... and check what happens.

In my case, the installation of visual C++ solved the problem of Udf Loading error message.

Just try it and tell us if it works.

Sangeeta March 18, 2007 11:27

Re: load libudf problem
Tania, i installed visual C++ also. but still it does not work.

Sangeeta March 18, 2007 11:37

Re: load libudf problem
Is it necessary to load the C++ in the same drive as fluent

Rizwan March 18, 2007 15:17

Re: load libudf problem
Sangeeta, can u please chek what enviroment variables u r using? their path? and the order they are defined used? please chek and let us know if there is some mention of path in system variables too.


soe March 19, 2007 09:12

Re: load libudf problem
Hi guys, i've had this problem before.1) Depending on the machine you're running on fluent's internal compiler builds the udf code with a "Makefile" script. This could be missing. 2) For starters, your udf .c file should be in the same directory as your .cas file, ie. in your working directory. 3) Also check your Fluent software folder for the SRC directory, it should have all the header .h files inside to build the preprocessor directives in your code. 4) i'd like to know if your code even builds correctly at all before you load it. What does Fluent say about the building process? If you code was not built, you can't load, it will give you the load libudf problem. Anyway if any of those stuff i mentioned above is happening then the building will definitely fail. If nothing helps, try to find the "log" file in your working directory, send it to the fluent guys, they'll figure it out for you. They'll know what's wrong.

Rizwan March 19, 2007 11:47

Re: load libudf problem
well in my case which i have been working on for a couple of days, its like im in the first stage itself. try to build but the nmake file not found, to my knowledge this is coz of not detection of nmake file (the compiler fluents hopes to find once u click build on compile panel) of vc++ by fluent. as for now, i can only suggest that it is related to properly definining the path in environment variables.


Tania March 19, 2007 12:35

Re: load libudf problem
I don't know if this will help. May be you should try to set the environment by doing :

Start-> Program-> Fluent Inc Products -> Fluent ->SET Environement

But this should have been done right after the installation of Fluent.

Rizwan March 20, 2007 00:04

Re: load libudf problem
No that is not my problem. I have good experience using fluent and writing udfs (interpreted ones not compiled ones). anyways thanks for your response.

Sangeeta March 20, 2007 12:22

Re: load libudf problem
Soe, I am having UDf and case file in same drive(in windows). i am not able to build the udf. its says nmake is not recognized as an internal or external, operable program or batch file.

I am Having the SRC and log file also.

So can u plz tell me the reason for not building


soe March 21, 2007 08:03

Re: load libudf problem
Hi Sangeeta,

Did you send the fluent guys the log file? Let me see it as well, i'll see if it's a similar problem to mine. Computers are funny, for all you know if you try it on another machine, you might actually be able to compile.

All times are GMT -4. The time now is 11:38.