CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Fluent UDF and Scheme Programming (
-   -   UDF compiling problem (

Wouter August 11, 2008 13:18

UDF compiling problem
I have some problems with compiling UDF's in Fluent. I've looked around at this forum and already tried some suggested solutions but none of them could really solve the problem. At first the following error occurred when I builded and loaded the library in Fluent:

"'CANT FIND NMAKE' , 'CHNG DIRC' (chdir "libudf")() (chdir "ntx86\\2ddp")() 'nmake' is not recognized as an internal or external command, operable program or batch file. 'nmake' is not recognized as an internal or external command, operable program or batch file."

This was solved when I installed Microsoft Visual Studio 5 Express (which includes a command line compiler) and I put nmake in the path. But then the following error occured: "Opening library "libudf"... Error: open_udf_library: The system cannot find the file specified. Error Object: ()" The log file in the ntx86 folder of the libudf folder shows that the following error occurs: "NMAKE : U1077: '"c:\Program Files\Microsoft Visual Studio 8\VC\bin\cl.EXE"' : return code '0xc0000135' Stop."

I saw in some solutions to this problem that sometimes a little change to the environment variables has to be made to solve the problem (I already had to add to the path manually the folder in which nmake was located). I'm not an expert in this kind of things, my question is as follows: should I add/delete more information to the environment variables (user and system variables) to solve this problem and if so which variable do I have to add/delete and which corresponding value?

Maybe I'm totally wrong and it doesn't have anything to do with the environment variables. In that case, does someone have an idea what the problem could be? Maybe it's a problem related to the UDF I've written?

Best regards

ranaca August 30, 2010 11:36

loading udf
Hi! I have a problem when loading the compiled udfs. I am a begginer and I am doing the tutorials from the website. The thing is, I make sure that the the .c files and the mesh and .cas dat files are in the same folder as it is requiered. Then I go to the copiled udf panel, select the .c files I need and build them, but when clicking in load, I got the following error:

Opening library "libudf"...
Error: open_udf_library: The system cannot find the specied file.

I dont know why this is happening. Maybe the program is unable to find the rute to that library or even dont have the library, but I dont think I dont have it.

Thanks for your help!!!

bhupesh143g1 August 30, 2010 11:40

Hi there
no -such file

WHERE ARE YOU RUNNING YOUR fLUENT? iF U R RUNNING IT ON UR PC THEN, the case is it doent hv a compiler to compile ur .c files and hence the error.

divyat August 31, 2010 03:11

Hi ranaca,
Instead of compile, you interpret the source file by keeping the source,case,data files in one folder. Interpreting is easy than have to follow the same process to interpret as you done for the compile.

FrAnKeN.s. + .e!N. February 2, 2011 03:54

hey divyat,

i tried both the methods compiling and interpreting. but while interpreting it shows Error: C:\Users\Desktop\fluent\DynMesh\valve.c: line 57: parse error.
is there anything i can do about it ?


amirreza_m February 2, 2011 06:29

the best way is to launch fluent from Microsoft VC++ command prompt after putting fluent in the path. simply try this (~\Fluent\ntbin\ntx86\setenv.exe)
also using compiled UDFs are more conservative than interpreted ones because of many reasons.

The_Architect June 6, 2012 04:43


on a PC you will first have to install Microsoft VC++. Once installed, you have to start Fluent from the VC++ command line. Navigate in the command line to the directory where Fluent is installed and then run the .exe file to start Fluent. After this is done, you should be able to compile .C UDF:s in Fluent.

All times are GMT -4. The time now is 11:13.