CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Fluent UDF and Scheme Programming (
-   -   UDF parallel error: chip-exec: function not found????? (

shankara.2 August 12, 2009 18:48

UDF parallel error: chip-exec: function not found?????
Hi all

I'm using a DEFINE_DPM_BC UDF on a wall in my domain. It's been running fine on serial for my previous cases. Even for parallel, I used the #if !RP_HOST and #endif commands within my UDF and it worked fine. I'm using the same UDF for a new case now.

When I run in parallel, I get the msg "Error:chip-exec: function 'none' not found'. I used some print statements inside my UDF to see if the UDF is getting executed but from what I see, FLUENT doesn't even go inside the UDF and none of the statements are printed. I'm guessing it's a problem with my parallel case. When I run the UDF in serial, it does get executed and I can see FLUENT passing through various stages of my UDF through the printed messages but after a while, I get the message 'Fluent process could not be started'.

What might be the problem here? I'm pretty sure nothing has changed in my system setup from when I ran my UDF successfully for my previous cases.
I did do something different but am not sure how much of an impact this will have on my UDF running correctly. Before I solved my flow field, I broke down the wall where the UDF will be applied into two. I used the Adapt-> Iso-value->Grid->Radial coordinate to mark some cells within a certain area on the wall and then used Separate->Faces to separate the wall into two regions and then solved my flow field. Now, the UDF is applied only to one region on my wall and I have reflect BC set on the other region. Not sure how much of a difference this will make.



brusly January 16, 2012 23:14

Are you using UDMI in your UDF? If you are using UDMI,Please set User defined memory.

All times are GMT -4. The time now is 19:02.