CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Problem in parallel Fluent under Ubuntu (loading MPI?) (

Alucard May 10, 2013 10:11

Problem in parallel Fluent under Ubuntu (loading MPI?)
I just installed a version of Ansys14.0 in Ubuntu.
In serial mode everything works fine but I cannot start properly the parallel (on a local machine) version.

This is the message I get (in the bottom lines part is where, I suppose, problems arise)
Can someone please help me?

HTML Code:

Loading "/usr/ansys_inc/v140/fluent/fluent14.0.0/lib/fluent.dmp.114-64"
/usr/ansys_inc/v140/fluent/fluent14.0.0/bin/fluent -r14.0.0 3ddp -pshmem -host -alnamd64 -t2 -mpi=pcmpi -path/usr/ansys_inc/v140/fluent -cx hellsing:60753:47595
/usr/ansys_inc/v140/fluent/fluent14.0.0/bin/fluent: 468: [: pcmpi: unexpected operator
Starting /usr/ansys_inc/v140/fluent/fluent14.0.0/lnamd64/3ddp_host/fluent.14.0.0 host -cx hellsing:60753:47595 "(list (rpsetvar (QUOTE parallel/function) "fluent 3ddp -flux -node -alnamd64 -r14.0.0 -t2 -pshmem -mpi=pcmpi ") (rpsetvar (QUOTE parallel/rhost) "") (rpsetvar (QUOTE parallel/ruser) "") (rpsetvar (QUOTE parallel/nprocs_string) "2") (rpsetvar (QUOTE parallel/auto-spawn?) #t) (rpsetvar (QUOTE parallel/trace-level) 0) (rpsetvar (QUOTE parallel/remote-shell) 0) (rpsetvar (QUOTE parallel/path) "/usr/ansys_inc/v140/fluent") (rpsetvar (QUOTE parallel/hostsfile) "") )"

    Welcome to ANSYS FLUENT 14.0.0

    Copyright 2011 ANSYS, Inc.. All Rights Reserved.
    Unauthorized use, distribution or duplication is prohibited.
    This product is subject to U.S. laws governing export and re-export.
    For full Legal Notice, see documentation.

Build Time: Oct 25 2011 11:19:48 EDT  Build Id: 10398
Loading "/usr/ansys_inc/v140/fluent/fluent14.0.0/lib/flprim.dmp.1119-64"

    This is an academic version of ANSYS FLUENT. Usage of this product
    license is limited to the terms and conditions specified in your ANSYS
    license form, additional terms section.    --------------------------------------------------------------
Host spawning Node 0 on machine "hellsing" (unix).
/usr/ansys_inc/v140/fluent/fluent14.0.0/bin/fluent -r14.0.0 3ddp -flux -node -alnamd64 -t2 -pshmem -mpi=pcmpi -mport
/usr/ansys_inc/v140/fluent/fluent14.0.0/bin/fluent: 468: [: pcmpi: unexpected operator
Starting /usr/ansys_inc/v140/fluent/fluent14.0.0/multiport/mpi/lnamd64/pcmpi/bin/mpirun -np 2 /usr/ansys_inc/v140/fluent/fluent14.0.0/lnamd64/3ddp_node/fluent_mpi.14.0.0 node -mpiw pcmpi -pic shmem -mport
sh: 1: export: 14: bad variable name
mpirun: rsh: Command not found

Alucard May 10, 2013 14:53

Ok guess I solved it
if I run Fluent as:

fluent -r14.0.0 3ddp -t4 -mpi=openmpi

basically I choose manually the mpi library I want it works.
I don't know why it doesn't like the pc mpi one but beeing practical
I will going on using openmpi.

fluent-newbie October 22, 2013 16:37

Problem in parallel Fluent under Ubuntu (loading MPI?)
we have the same issue.
were you forced to use openmpi, where you ever able to use pcmpi ?

All times are GMT -4. The time now is 14:22.