CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Error in Parallel Fluent (

randomPhil July 23, 2013 07:29

Error in Parallel Fluent
hi all,

I am trying to run Fluent v14.5 on 16 cores and am having a problem.

Sometimes when I click cancel to interrupt the iterations, it stops as normal then around a second later Fluent disappears without any warning.

When I check the error log file it says:
"Error [node 999999] [time 7/23/13 12:21:41]".

Does anyone have any idea how I can fix this?

Any help would be greatly appreciated.


randomPhil July 23, 2013 07:40

sorry I left out a bit at the end of the error message, the full message should read:

"Error [node 999999] [time 7/23/13 12:21:41] Abnormal Exit!"

any help would be hugely appreciated!!!

Eeethon October 8, 2013 22:38

the same problem
I countered the same problem ,too.Is there anybody can help me out?Thanks

HHOS October 22, 2013 06:47


I see that you opened the thread some months ago. Did you find a solution?? Because I am facing the same problem!!!!! :(

Thank you!

vasava October 22, 2013 08:51

Although I am not sure but this may have something to do with node-master communication.

I also suggest you try different method for mesh partition for parallel calculations.

HHOS October 22, 2013 08:59

what do you mean with node-master communication??

The problem happens with the version 14.X, when I run the case with Fluent 12.X, there is no problem...

Before closing the window automatically, it shows "[...]fluent14.5.7\cortex\win64\cx1457.exe received fatal signal (ACCESS_VIOLATION)"

I tried to execute just the cx1457.exe, and it says that a dll file is missing, but it is actually there!!!

Any clue??

Thank you!

vasava October 23, 2013 01:25

I am not a cluster geek but all I understand is this: if you dont have your MPI set right then there could be issues with communication between nodes.

The 'node 999999' error also has something to do with UDFs. If your UDF is not compiled with right program (32 bit-64 bit) or right way then there could be some issues.

If you using academic license then it also comes with some limitations e.g. no. of node that can be used for parallel process.

shivakumar July 18, 2014 02:09

I'm also having the same problem.

Any help would be appreciated.

vasava July 18, 2014 05:02

Whats exactly is the problem with ansys?

shivakumar July 18, 2014 06:02

I tried different methods still am getting the same..:(

How to overcome from "abnormal exit of fluent"??

vasava July 24, 2014 02:36

Whats exactly you do during or after which the fluent closes abruptly?

shivakumar July 24, 2014 04:36

I'm thinking that problem may be due to the boundary conditions, even I tried changing the BCs. But still it is getting the same error and disappearing without giving any information. I'm not understanding what to with this..:(

"Error node [99999] Abnormal Exit"..

Any help would be appreciated...


Gates Jobs November 16, 2014 23:52

I use ansys15.0 to simulate a transmission,I also encounter the same problem sa yours,have you solved it?
Thank you!

LuckyTran November 17, 2014 09:12

Try using a different MPI or playing with your MPI settings.

shivakumar May 3, 2015 14:02


Originally Posted by LuckyTran (Post 519566)
Try using a different MPI or playing with your MPI settings.

I tried everything discussed in this forum still getting the same error [abnormal exit]. I am using another system to run..

shereez234 May 3, 2015 18:31


I do not know exactly how to solve the problem you are facing: But i will share my experience of parallel fluent -

PBS File looks like:

### PBS ###
#PBS -l nodes=2 : ppn=8 ( Ok there is no space between : and ppn but I had to use it because a weird emoticon :p << keeps coming up)
#PBS -l walltime=30:00:00
#PBS -j oe
#PBS -o FILE.log
#PBS -N Jobname
cd /home/usr [ This is where you are submitting your job from so figure it]
/data1/ansys/v150/fluent/bin/fluent 3ddp -i pressurebased.jou -t16 -g -mpi=openmpi -ssh >> logfile

OK So using these settings you can create the batch file. Now for the journal file make sure you have it saved in unix format: You can definitely create it in windows also, and transfer it to the linux system: Open the file using VIM editor ( that's what I use) and follow these commands:

:w ( write the file once more)
: set ff=unix ( set the file format as unix)
:wq ( write and quit the file)

hope it gets sorted now: :) if not come back and ask i will try to help

shivakumar May 6, 2015 06:44

Thanks for the reply.. Nothing worked for me, still the fluent is spitting the same error.

thomas. September 1, 2015 13:27

I know this is an old thread, but did you have any luck with this problem?

LuckyTran September 1, 2015 16:28


Originally Posted by thomas. (Post 561999)
I know this is an old thread, but did you have any luck with this problem?

This is usually an intermitten problem with parallel FLuent and it's usually a problem with the MPI. Is your problem intermittent or does it always happen? Try using a different MPI or reconfiguring your current MPI.

shivakumar September 1, 2015 23:55

I tried every settings which are discussed in this forum but couldn't solve it.
Finally, I Uninstalled ANSYS 14.0 and installed 15.0 version, the problem disappeared automatically.


All times are GMT -4. The time now is 05:51.