CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Injection Particles coordinate (

noa November 13, 2013 06:52

Injection Particles coordinate

I am using Define Injections.. in order to set particles in my simulation.
I have 360 particles and of course its unreasonable to set each particle (x coordinate y coordinate ) manually. Is there away to insert the particles location through a file? Does someone has an example of a file like that???

Thank you

pakk November 13, 2013 08:58

Do this with an injection file.

In your case it will have 360 lines. Each line is like this:

(( -0.25779 -2.7189e 0.221755735 17.2234848 14.53586671 0.1235 2e-5 295.398 1e-20 ))

xpos, ypos, zpos, xvel, yvel, zvel, diameter, temperature, flow rate

You still have to supply the 360 lines, but you can write a small program to do this, for example in matlab.

noa November 14, 2013 05:06

Thank you for your respond. However, I tried to save that line into a file *.inj
and when I tried to read it through injection I got this error message:

Error: ASSQ: invalid argument [2]: improper list
Error Object: -2.7189

pakk November 14, 2013 08:23

"-2.7189e" should be " -2.7189" (my typo, sorry)

noa November 14, 2013 09:43

I know, and I already fixed it. My model is 2D so I also changed the file to this line and it still doesn't work:

((-0.25779 -2.7189 17.2234848 14.53586671 2e-5 295.398 1e-20 ))

Thank you,

pakk November 14, 2013 10:32

Hmm, can't help you further, the example works for me, sorry...

czhao86 November 14, 2013 15:22

I have a matlab code which is good for writing the file for injecting particles in a rectangular cross section. If you are interested, I can send you the file.

noa November 15, 2013 06:33

Thank you very much !

Please send it (

noa November 20, 2013 03:53


Thank you, I generated the file, it looks very good, but I get the same error:

Error: CAR: invalid argument [1]: wrong type [not a pair]
Error Object: id
Importing the following injections:
Error: CAR: invalid argument [1]: wrong type [not a pair]
Error Object: id

pakk November 20, 2013 06:48

Do you get the same problem if you put in the positions manually?

mit.R November 24, 2013 04:46

ingection particle

Originally Posted by pakk (Post 462683)
Do you get the same problem if you put in the positions manually?

Hi All

I have a source that generat several defferent particles and finaly as smok plumn spread in ambient.
I donít have informations about X&Y position or velociy for first & last point of particles, just I can supposedly determinate name, diameter & flow rate of particles.
I am going to modeling particles generated frome welding process by fluent and showing particle concentration contour , do I should used DPM Concentration for this case ?
But I donít know why befor injections and display -->particle tracks-->particle variables -->parricle residence time --> error softward
And when discrete phase model-->DPM Concentration -->display--> it is show nothing
Other question: in near the source creat temprature about 3000-10000 K , but far frome the source gragually is decrease temprature defferent between smok plumn and ambient. Do is flow unsteady & compressibility? Or it is negligible with some assumptions for Simplifying
Plz , advice me, tanx

noa November 26, 2013 08:32

no, I don't. It works when I do it manually, but its hard to put 360 particles

alechan May 8, 2014 06:39

Noa, have you finally solved it? because I have a simillar error and I dont know why, my error is:

Error: CAR: invalid argument [1]: wrong type [not a pair]
Error Object: 1

And my injections are like this:

((0.000000e+000 1.187500e-002 0.000000e+000 8.600000e-004 0.000000e+000 0.000000e+000 9.5000000e-003 2.981500e+002 1.401388e-002) 1)

noa July 7, 2014 13:40

Did someone solve it?

alechan July 10, 2014 05:30


Originally Posted by noa (Post 500466)
Did someone solve it?

I sent you a private message long time ago

noa July 11, 2014 03:07

right, but still it didn't work. Did u do it lately?
Can u send your files again?

Thank you:confused:

alechan July 11, 2014 03:45

I dont remeber it very good, but I think it was not a problem with the file, the problem was the path you use to read it, the correct way is:

Models, discrete phase, injections, create, and in injection type you have to select file, then between OK and cancel (down part) you select file again and select your injection file.

With this it worked to me :)

noa July 11, 2014 07:16

Thank you, I will try.
Can u please send me the files again.

Nuha July 21, 2016 00:24

Dear Rexxar

Could you please mail me file injection code that you have , at this email id :

Thank you in advance

All times are GMT -4. The time now is 03:26.