CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   error when writing data (

macfly January 29, 2014 18:09

error when writing data

Fluent crashes when it tries to write data and I don't know why.
- Windows 8.1
- Ansys 14.5.7
- 3D model with turbulence, combustion, etc.
- Fluent launched in parallel mode and mesh automatically partitioned

Here is the message in the GUI:

Writing "| gzip -2cfv > D:\init.dat.gz"...

999999 (..\src\mpsystem.c@1172): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 32 bytes: No such file or directory
MPI Application rank 0 exited before MPI_Finalize() with status -1073741819
The fl process could not be started.

Error: Error writing "| gzip -2cfv > D:\init.dat.gz".
Error Object: #f

Message from Cortex process==> Connection with host is broken. It may have crashed.

Any idea please??? Thx

diamondx January 29, 2014 20:59

it says no such file or directory ? is the d: and external hard drive ? may be it's unplugged ?
Have you tried another location ?

macfly January 29, 2014 23:26

No, I run a dummy test case with the same commands, same udf, and everything works fine.

It just doesn't work with my big model, although my model is not that big with 250000 cells and 10-12 variables.

It's very annoying and I read all kinds of half-answers going in every directions online... Confused and don't know what to do except lighten my model step-by-step and going by elimination.

macfly January 29, 2014 23:31

same problem in that thread, what the hell am I supposed to do with answer #2...?:

diamondx January 30, 2014 12:24

he is refering to the type of MPI, when you launch FLUENT you get the right to choose in the parallel setting from diferrent king of mpi: pcmpi, intel...

macfly January 30, 2014 12:32

I always use pcmpi on Colosse, and you? If I use another mpi there is a message that recommends using pcmpi instead, somewhere in the output files..

From reading around, I think it has to do with the mesh partitioning. I added a line in my .jou telling Fluent to partition with another method than the default Metis. I'll see if it works.

I also read that it may be good to modify/save the case in serial, then launch it in parallel, for some obscure reasons...

diamondx January 30, 2014 12:39

[QUOTEI always use pcmpi on Colosse, and you?][/QUOTE]
me too.
Did you get this error message on colosse or you desktop ?

macfly January 30, 2014 12:43

both, local and Colosse

macfly February 3, 2014 16:23

In the end, it looks like the default 'Metis' mesh partitioning method was causing some data communication problems. I changed the partitioning method to 'Cartesian Axes' and the write-data doesn't cause me headaches anymore.

Couples of hours lost on that!

All times are GMT -4. The time now is 23:11.