CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Can some one check the validity of the injection file

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By `e`
  • 1 Post By `e`

Reply
 
LinkBack Thread Tools Display Modes
Old   August 18, 2015, 07:51
Default Can some one check the validity of the injection file
  #1
Member
 
Shaheer
Join Date: Jul 2015
Posts: 34
Rep Power: 4
Shaheer is on a distinguished road
Hello I have been trying to insert some particles via the discrete phase in fluent hence used a script to feed in the particles.
There are thousands of such but i made a file with only 4 just to see if its working.
When i try to use list function to see if its reading it right in the dialogue box i get this
Quote:
Particle streams from injection-0:
STREAM ...........................INITIAL VALUES...........................
NO TYP (X) (Y) (Z) (U) (V) (W) (T) (DIAM) (MFLOW)
further clicking list gives 2 additional message after this
Quote:
ERROR reading particle 0 for injection: injection-0.
4 particles not found in injection injection-0
I have attached the text file for the script. Please can any one see what mistake am i doing? and if possible could any good samaritan fix it and run to see if the injection is working or not.
I would be really grateful for this since i am working on a research and am stuck in this issue for a long time.
Help will be really appreciated.
Attached Files
File Type: txt injection_new.txt (386 Bytes, 24 views)
Shaheer is offline   Reply With Quote

Old   August 18, 2015, 08:41
Default
  #2
`e`
Senior Member
 
Join Date: Mar 2015
Posts: 800
Rep Power: 11
`e` is on a distinguished road
Remove the first line of the file which states the variables of the particle injection. Fluent is trying to read this line as an injection and is receiving strings where real numbers are expected.
Shaheer likes this.
`e` is offline   Reply With Quote

Old   August 18, 2015, 08:47
Default
  #3
Member
 
Shaheer
Join Date: Jul 2015
Posts: 34
Rep Power: 4
Shaheer is on a distinguished road
thank you i did that too before but i used to get
Quote:
4 particles not found in injection injection-0
hence i added the first part.
Can you just feed it into a system to see if its working in your end ?
Shaheer is offline   Reply With Quote

Old   August 18, 2015, 20:51
Default
  #4
`e`
Senior Member
 
Join Date: Mar 2015
Posts: 800
Rep Power: 11
`e` is on a distinguished road
I've tested the injection file (without the first line) in a simple cube flow cell and the particles are injected and tracked as expected. There must be an error somewhere else in your model setup.
Shaheer likes this.
`e` is offline   Reply With Quote

Old   August 20, 2015, 05:04
Default
  #5
Member
 
Shaheer
Join Date: Jul 2015
Posts: 34
Rep Power: 4
Shaheer is on a distinguished road
Thank you very much for this. I have been obcessed that there has been some error in my scripting the data. Now i know problem is elsewhere.
Shaheer is offline   Reply With Quote

Old   February 2, 2017, 11:51
Default
  #6
New Member
 
Join Date: Dec 2016
Posts: 11
Rep Power: 2
TimTUBAF is on a distinguished road
Hi guys,

I'm stucked on the same problem, same error message...

Did you figure out where the problem is/was ?


Thanks
TimTUBAF is offline   Reply With Quote

Old   February 2, 2017, 12:17
Default
  #7
Senior Member
 
Join Date: Nov 2013
Posts: 1,074
Rep Power: 14
pakk will become famous soon enough
It means that the coordinates that you give (or at least the one that Fluent reads) are outside of your fluid domain.
pakk is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SparceImage v1.7.x Issue on MAC OS X rcarmi OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 4 August 14, 2014 06:42
build problem swak4Foam OF 2.2.0 mcathela OpenFOAM Installation 14 April 23, 2013 13:59
Version 15 on Mac OS X gschaider OpenFOAM Installation 120 December 2, 2009 11:23
Problems in compiling paraview in Suse 10.3 platform chiven OpenFOAM Installation 3 December 1, 2009 08:21
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 20:08


All times are GMT -4. The time now is 05:28.