CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > FLUENT

Ansys fluent PEMFC addon: Getting 0 Current during simulation??

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 16, 2019, 12:30
Post Ansys fluent PEMFC addon: Getting 0 Current during simulation??
  #1
New Member
 
Yves Herbartz
Join Date: Dec 2019
Posts: 2
Rep Power: 0
Michael104 is on a distinguished road
Hey everyone,
i am trying to calculate the heat production of a fuel cell and have some question. Therefore i want to use the PEMFC addon and plot the temperature of a single channel pem-fuel cell. I am using fluent 2019 R3.


**Question:**
When I run the case the the current decreases for anode and cathode from higher values to 0 A/cm². Also the the V-Open deceases from ~1.2 V to lower values like 0.8 V. After 20 Iterations i received the error floating point (see picture below). Does anyone knows what i am doing wrong?? I tried allot but nothing helps.
Thanks for any Help.


Settings:
- I created a single fuel channel without cooling, with mpl, cat, gdl,(fluid) ; mem & current collector (solid), with hex-mesh, 0.5mm x 0.5 mm x 30 mm channel with 101920 elements.


-I imported the geometry into ansys fluent and uses most of the default pemfc-addon settings,set under relaxation factors in PEMFc gui panel to disv´d-vap/liq. source to 0.01 and osmotic drag source to 0.5. Solution controls under relaxation factors to 0.3 for pressure and 0.3 for momentum, all other set to 1, operating pressure 200000 pa, temperature to 343 K and mass flow inlet anode to 3e-6 kg/s and cathode to 0.00011 kg/s. Wall terminal anode is set to 0 V and cathode to 0.3 V. Like it is said in the" Ansys fluent best practice document" I run the first 25 iterations without Joule heating and reaction heating, after these first iterations with most of the model options ( except anisotropic E-Cond. and Liquid Phase).



**Question:**
When I run the case the the current decreases for anode and cathode from higher values to 0 A/cm². Also the the V-Open deceases from ~1.2 V to lower values like 0.8 V. After 20 Iterations i received the error floating point (see picture below). Does anyone knows what i am doing wrong?? I tried allot but nothing helps.
Thanks for any Help.

Michael
Michael104 is offline   Reply With Quote

Reply

Tags
floating point error, fluent, pemfc model

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPU acceleration in Ansys Fluent flotus1 Hardware 52 February 27, 2021 11:28
2D or 3D simulation of particles in ANSYS FLUENT Mostafa Barghash FLUENT 0 November 30, 2019 09:13
Start new Ansys Fluent Simulation automatically Malue Fluent UDF and Scheme Programming 1 October 4, 2017 01:48
Shock Tube Simulation in Ansys Fluent MHS78 CFD Freelancers 0 July 28, 2016 07:12
Comparison between Solidworks Flow Simulation and Ansys Fluent Bruce828 Main CFD Forum 5 February 23, 2013 10:13


All times are GMT -4. The time now is 18:17.