CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > FLUENT

Bug in FLUENT, must be fixed!!

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By LuckyTran

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 2, 2022, 14:15
Thumbs down Bug in FLUENT, must be fixed!!
  #1
Member
 
Ash Kotwal
Join Date: Jul 2016
Location: North Dakota, USA
Posts: 84
Blog Entries: 1
Rep Power: 8
Ash Kot is on a distinguished road
Hello All,

So this is just it! Don't understand how ANSYS sell bad product and get away with it!

If the TUI command used:
Code:
> solve/initialize/init-instantaneous-vel


 Warning: 

 This function is deprecated and will be removed soon. Please use the alternative 'init-turb-vel-fluctuations'
The above mentioned command shows up, alright understood no problem!
moving on now using following command:
Code:
> solve/initialize/init-turb-vel-fluctuations
invalid command [init-turb-vel-fluctuations]
What is this exactly?! This is wrong absolutely wrong!
the previous command is deprecated and other new command is not present.

And without this command, absolutely sure LES simulation is going to crash!

THIS COMMAND MUST BE FIXED!

This is paid version of fluent, its an enterprise version.
FLUENT Revision: 21.2.0 for ANSYS 2021 R2
Ash Kot is offline   Reply With Quote

Old   April 2, 2022, 16:10
Default
  #2
Senior Member
 
Lucky
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 5,025
Rep Power: 60
LuckyTran has a spectacular aura aboutLuckyTran has a spectacular aura aboutLuckyTran has a spectacular aura about
Did you enter this before or after you activated LES? needs to be before

If you think it's a bug, submit it to Ansys customer support and not to a random internet website. You can come here if you just want to vent and throw a tantrum, that's fine.
karachun likes this.
LuckyTran is offline   Reply With Quote

Old   April 2, 2022, 16:14
Default
  #3
Member
 
Ash Kotwal
Join Date: Jul 2016
Location: North Dakota, USA
Posts: 84
Blog Entries: 1
Rep Power: 8
Ash Kot is on a distinguished road
Yes sir! The LES model was not activated, I searched on the same forum and learned that, it may be available after switching to Transient from Steady-state but before LES. And I see no such command available.
Ash Kot is offline   Reply With Quote

Old   April 2, 2022, 16:53
Default
  #4
Senior Member
 
Lucky
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 5,025
Rep Power: 60
LuckyTran has a spectacular aura aboutLuckyTran has a spectacular aura aboutLuckyTran has a spectacular aura about
So if you go into the /solve/initialize menu and press Enter... What gets printed? The command shows up or it is missing?


If it is missing then either:
1) You are using workbench and not Fluent standalone
2) Someone else disabled the command in your environment
3) You didn't install ansys the same way as everyone else
4) You are using a RANS model which doesn't have a k field, or maybe not RANS at all.
LuckyTran is offline   Reply With Quote

Old   April 3, 2022, 01:22
Default
  #5
Member
 
Ash Kotwal
Join Date: Jul 2016
Location: North Dakota, USA
Posts: 84
Blog Entries: 1
Rep Power: 8
Ash Kot is on a distinguished road
The TUI command run this is what I see:
Code:
adjoint/                mesh/                   report/
define/                 parallel/               server/
display/                plot/                   solve/
exit                    preferences/            surface/
file/                   print-license-usage     views/

> solve

/solve> 
animate/                                        monitors/
cell-register-operations/                       patch
cell-registers/                                 report-definitions/
convergence-conditions/                         report-files/
execute-commands/                               report-plots/
initialize/                                     set/
iterate

/solve> initialize

/solve/initialize> 
compute-defaults/       initialize-flow         set-defaults/
fmg-initialization      list-defaults           set-fmg-initialization
hyb-initialization      reference-frame         set-hyb-initialization
init-flow-statistics    repair-wall-distance
So certainly the command is missing.

Disabled by anyone, highly unlikely! First time LES related simulations are conducted in organization and I'm the lead.

Its a stand alone fluent version, not within workbench. Also regardless how the FLUENT is running, the TUI command should be available and executed.

Its CentOS 7 based ANSYS installation, and its an enterprise version.
so certainly technical support during installation is provided, I shall still check with IT.

The situation is occurring in both k-Epsilon and k-Omega SST model, both are RANS models last time I checked.


Also, this is already reported to ANSYS customer portal. On this well known CFD forum, I'm just alerting fellow members so that before they jump into LES to see beautiful contours of flow, they'll makeup their mind to see divergence occurring on every timestep. Because, FLUENT has bug in system.
Ash Kot is offline   Reply With Quote

Old   April 3, 2022, 05:56
Default
  #6
Senior Member
 
Lucky
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 5,025
Rep Power: 60
LuckyTran has a spectacular aura aboutLuckyTran has a spectacular aura aboutLuckyTran has a spectacular aura about
I've never used enterprise version so I can't tell you what are its limitations.

There are configuration files that can block out certain commands from being available and workbench also uses these configuration files to limit specific thingies from being done that wouldn't make sense in a workbench environment. Even when workbench is not involved, these configuration files can still be set.

I've never used enterprise edition so I can't tell you what limitations there might be. I've used it on RHEL and Windows and it's there.

If your LES diverges without the command then you're already in trouble.
LuckyTran is offline   Reply With Quote

Reply

Tags
bug, tui command

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluent Airfoil Analysis: Fixed CL mode Bulk FLUENT 0 February 28, 2017 05:25
problem in using parallel process in fluent 14 aydinkabir88 FLUENT 1 July 10, 2013 02:00
interface not working, bug in fluent? MachZero FLUENT 2 June 9, 2013 07:22
is fluent capable in fixed beds simulation? crazycrow58 FLUENT 1 November 21, 2010 20:18
few quesions on ANSYS ICEMCFD and FLUENT Prakash.Paudel ANSYS 0 August 12, 2010 12:07


All times are GMT -4. The time now is 09:32.