CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Unsteady Velocity - UDF in parallel (

Prateep Chatterjee October 25, 2001 16:16

Unsteady Velocity - UDF in parallel
I've failed to make my UDF, which computes a time dependent inlet boundary velocity, to work on an Origin 2000 multi processor machine. here is the C code:

#include "udf.h"

DEFINE_PROFILE(unsteady_velocity, thread, position)

{ face_t f;

/* #if !RP_HOST */

begin_f_loop(f, thread)


real t = RP_Get_Real("flow-time");

F_PROFILE(f, thread, position) = 0.01789 + 0.001789*sin(20.*t);

} end_f_loop(f, thread)

/* #endif */


can anybody point out what changes should I make to the code to make it work in parallel ? the error comes out as:

"chip-exec: unsteady_velocity not found"

I've tried to make changes after looking at files from Fluent. I have some info. related to UDFs in parallel @ wasn't able to solve the problem though.

hampton November 6, 2001 05:35

Re: Unsteady Velocity - UDF in parallel

Your UDF is perfect. However, Did you select the "unsteady_velocity" in the boundary conditions panel ?


Prateep Chatterjee November 6, 2001 10:44

Re: Unsteady Velocity - UDF in parallel
yes, I did select the function in the BC panel. I've found out the error:

the "cpp" being used for compiling the UDF was not in the path of NQS batch scheduler! so, all my efforts in trying to find errors in the UDF/Fluent was a complete waste of time. so, in reality, the UDF wasn't getting compiled at all.

hampton November 7, 2001 04:23

Re: Unsteady Velocity - UDF in parallel

Are you using "interpreted UDF" ,aren't you?. In case of this kind of problem, there are possibilities that your system couldn't find the "cpp" during the iterations as you mentioned. So, I recommend changing into "complied UDF". Then, the problem will be solved.

About "complied UDF",please refer to Chapter 24 in FLUENT User's Guide .


Volker Pawlik November 23, 2001 05:40

Re: Unsteady Velocity - UDF in parallel
It is necessary that all cpus or machines find the udf. Hence the path has to be same for all yor machines in the cluster. If not you will get such a message.


All times are GMT -4. The time now is 00:26.