CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Grid type in GAMBIT (

Christian January 18, 2002 06:11

Grid type in GAMBIT

I have a problem meshing a volume. I have meshed all the surfaces with squares, but when I try to mesh the volume with the Cooper tool, I get an error. Gambit wants to mesh the volume with tri's.

Does anyone know why I cannot mesh with Hex cells when all the faces are meshed with squares ? Is it again the vertex types that are to blame ?

Cheers Christian

Erwin January 18, 2002 11:12

Re: Grid type in GAMBIT
First of all, if you mesh all faces with quads that's no guarantee that your volume is mappable or cooperable. Check to manual to see if your volume adheres to the requirements for Coopertool (needs to be a barrel with 2 endcaps).

If it is possible to Cooper but Gambit can only come up with a TGrid scheme, that's because Gambit is sometimes to dumb to figure it out by itself. You can force it to Cooper by setting Element to Hex or Hex/Wedge, and then to select the Type as Cooper. This usually also means that you have to specify all source faces.

Be sure to select your 'target' source face last. Be also sure not to have a mesh on your target face.

All times are GMT -4. The time now is 02:43.