CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Using Fluent with VNC (

ugur June 26, 2003 17:39

Using Fluent with VNC
I just installed vncserver on a RH 8.0 workstation. Whenever I try to use fluent with vnc, the menu text characters doesn't display correctly> Is there anybody knows why this happens and how to fix it?



jx June 28, 2003 15:40

Re: Using Fluent with VNC

I did this way also, if you mean you run Fluent on the machine where venserver is running on and connect it from another machine with vncviewer. I even run Fluent on x0rfbserver. Both way I have no problem.

Both vncserver and x0rfbserver do all actual work on the server machine. While vncviewer just makes a exact copy of the screen.

Therefore, I believe your problem lies on the server. More specifically, it might be a font problem. If you have physical access to the server machine, you can try run it there directly, to see if the problem comes up or not. If you can not, you can run Fluent over ssh with X-forwaring. The difference is that this way the font rendering is done on your client machine. You have to run X server on your client amchine though. For *nix, you already have X installed, for windows, you can choose Exceed (coming with gambit, so in Fluent CDs), X-win32, Cygwin+XF86 (GPLed software, so free), or others.

Hope this helps.

jx June 28, 2003 15:52

Re: Using Fluent with VNC
Sorry, precisely speaking, XFree86 is opensourced but not GPLed. But anyway, XF86 on cygwin provides you a free Xserver for windows. Also ssh is in the cygwin package.

Since you run Fluent on vncserver, this offer your another choice free from commercial software.


ugur June 28, 2003 17:01

Re: Using Fluent with VNC
Thanks for the repsonse. I do have physical access to the linux box, and when I run Fluent on the Xwindow of RH 8.0, I don't have any problem. So if this is a font problem, probably the xserver vnc is running doesn't recognize the font. Other than fluent menus, everything is fine. Is there anyway to modify fluent fonts to use a more standard font? ugur

jx June 28, 2003 19:25

Re: Using Fluent with VNC
That's odd then.

Maybe you should check the vncserver script to make it use same font path as X. I just remember vncserver is a script to invoke Xvnc, not sure if it sets up different fonts from the main X server.

I don't think fluent use wield fonts for its menu.

My suggestions are:

1. can you vncviewer to localhost to make sure the error happens on the server. 2. When on remote client machine, you can use ssh with X-forwarding and run X server on it. 3. use x0rfbserver. It works like WinVNCserver with windows. Since you can run fluent without problem on the server, you still use vncviewer to connect the server.


jx July 2, 2003 13:26

Re: Using Fluent with VNC

I just had the same problem when I tried to run fluent remotely on a server which I don't have physical access to.

I tracked down the vncserver (a perl script) and found there *is* font path settings in it. I just uncommented them and changed to

$cmd .= " -fp unix/:7100";

Then everything works.

Hope this helps.

ugur July 18, 2003 13:14

Re: Using Fluent with VNC
Thanks jx;

I tried it and it works.

All times are GMT -4. The time now is 16:03.