CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Udf loading error (

John June 5, 2004 13:30

Udf loading error
Hello all,

I am trying to solve the tutorial problem involving dynamic meshing. I have followed the steps given in the tutorial and copied the mesh file and the C source code into the C:FLUENT.INC\fluent6.1\src folder.

Now, I dont get any errors while building the UDF but when I attempt to load it, I see the following error message :

Opening library "dynamsh"... Error: open_udf_library: The system cannot find the file specified.

I would be glad if someone could help me with this problem.

Thank you,


kim June 7, 2004 08:18

Re: Udf loading error
Check the make.log file in directory "udflib". While compiling, errors which you haven't noticed might be generated.

John June 7, 2004 13:30

Re: Udf loading error
Hello Kim,

Thanks for ur reply. I did try to check up the makefile log but nothing seems to be wrong.

What I did look at was the fact that there are two header files being used : stdio.h and udf.h Fluent src directory does not have the stdio.h file while visual studio does not have udf.h.

I have microsoft visual studio installed in my computer, so i tried to copy the file stdio.h into the fluent working directory and tried building and loading the udf, but it again gave me the same error while trying to load the udf.

Do you think there are some system environment settings to be checked for both the softwares?

Eagerly waiting for responses. Thank you.


All times are GMT -4. The time now is 07:08.