CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   FLUENT parallel run (

Sampath November 10, 2004 04:25

FLUENT parallel run
Iam getting the following error mesg posted below while trying to run fluent in parallel.can anyone help me out with this?

Thanks, Sampath.

Command used: C:\>fluent 2ddp -pnmpi -path\\brick\ -cnf=hosts.txt -t2 Output in fluent: Loading "C:\Fluent.Inc\fluent6.1\lib\fl114.dmp" Done.

Welcome to Fluent 6.1.18

Copyright 2001 Fluent Inc.

All Rights Reserved Loading "C:\Fluent.Inc\fluent6.1\lib\flprim117.dmp" Done. Current fluent usage: 1. tcs@FLUID Tue Nov 2 16:09 FLUID 2. tcs@FLUID Fri Nov 5 1:29 FLUID 3. tcs@MACH Fri Nov 5 12:20 MACH 4. sharath@shell Fri Nov 5 13:41 shell 5. tcs@BRICK Fri Nov 5 15:09 BRICK

License for fluent expires 12-jan-2005. Host spawning Node 0 on machine "BRICK" (ntx86).

**** JobInfo **** JobInfo->hBarrierSemaphore [0] JobInfo->hBarrierEvent [0] JobInfo->hGlobalTerminatorEvent [0] JobInfo->dwNumMachines [2] JobInfo->dwWorldSize [2] JobInfo->dwMyMachineID [0] JobInfo->Machine [0] szMachineName [brick] dwNumProcesses [1] Process [0] Executable [\\brick\\fluent6.1\ntx86\2ddp_node\fl_nm pi6118.exe -mport node] dwLocalBufferNumber [0] dwMachineNumber [0] dwGlobalRank [0] hSharedMemoryBuffer [0] JobInfo->Machine [1] szMachineName [contact] dwNumProcesses [1] Process [0] Executable [c:\temp\fl_nmpi6118.exe] dwLocalBufferNumber [0] dwMachineNumber [1] dwGlobalRank [1] hSharedMemoryBuffer [0] Error getting port number of service! MPIRUN exited with status [0]

weirong November 13, 2004 14:43

Re: FLUENT parallel run
I am working on Fluent parallel processing too. Your problem should come from your clutser master node. The error said it could not get port in my understanding the port may be occupied by some other application. The most possible situation is that you did not close the previous parallel run, or it corruped but you did not clean it.

You welcomed to send me emails with furthur details. I am also working on fluent cluster now.

jyo November 15, 2004 07:26

FLUENT parallel run

I am very new to this fluent parallel processing. I was trying to run a case in fluent with two processors(one is my system where the fluent is installed and other one is my neighbouring system). But i was getting error in doing so. Can u please tell me the step by step procedure for running a case in fluent parallel processor.


Sampath November 16, 2004 04:16

Re: FLUENT parallel run
Thank you very much sir.

But my previous Fluent parallel run hung with same error,can you tell me how to clean out the error ? Other applications using MPICH are working fine on this cluster.. only with fluent Iam facing this problem of "Error getting port number of service!" Can you tell me if any manual settings are needed to resolve this, I have followed all instructions on Fluent support site for parallel runs.

Regards, Sampath.

wei rong November 16, 2004 11:25

Re: FLUENT parallel run
Suggestion to both:

There is complex situation when running fluent parallel. Please make sure the master node can rsh peer without password. Make sure same dir shared on master node and shared peer, etc. So I suggest you can run a fluent parallel case on single computer(maybe master) first, using process paralleling, that what I did while having such problem. So that you can tell the problem came from master or from the connection between master and other nodes.

jyo November 24, 2004 03:11

Re: FLUENT parallel run

we have tried fluent parallel processor in windows and it is working fine. Now i am trying from windows to linux m/c. Can u please help us in this problem?



wei rong November 24, 2004 10:52

Re: FLUENT parallel run
sorry, what is m/c? I do not see a way running parallel between different OS.

All times are GMT -4. The time now is 12:58.