CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Parallel Fluent on Linux clusters (

Chengwang Lei November 23, 2004 01:06

Parallel Fluent on Linux clusters
Dear Fluent users,

I am an inexperienced user of Fluent (version 6.1.22) and a new user of Linux clusters. The cluster that we have consists of 16 Pentium 4 2.66GHz processors with a 1-gigabit switch, and the OS is Debian Linux 2.4.26.

At the moment I am trying to run Fluent in parallel on the linux cluster but with no success. The fact is that when I ran a 2D test case of about 51,500 cells with 4 processors, I got about 4 times slowdown instead of speedup compared with the speed of the serial job with a single processor. The partition was done by Fluent automatically in that particular case.

I am wondering if anyone can give me some advices or point me to any sources for information with regard to running parallel Fluent processes on linux clusters.

Thanks in advance.


mange November 23, 2004 05:55

Re: Parallel Fluent on Linux clusters
Maybe you should try a bigger test case. In your case the transfer time of data between computationalnodes is dominating over actual iteration time.

Chengwang Lei November 23, 2004 19:23

Re: Parallel Fluent on Linux clusters
I have tried the same case on a different platform and got about 3.8 times speedup. So probably the size of the test case is not an issue.

jyo November 24, 2004 03:05

Parallel Fluent on Linux clusters

We are new to fluent parallel processor. But we have tried recently fluent parallel processor in windows machines. Now we want to try using linux machines. (i.e)From windows to linux machines. We have fluent in our windows system and clusters are linux m/cs. We have tried in the following way:

We have opened fluent from windows m/c using the command "fluent -serv -a". Then we use the run command from file menu and default was selected as communicator, then we clicked listen button. We have logged on to linux m/c using telnet and we have tried the following command "fluent 3d -psmpi -t2 -cx windows system ipaddress:some number:some number" We got the following messge bash:fluent:command not found

If u can help us in this regard,it will be useful for us.

Thankyou jyo

All times are GMT -4. The time now is 01:56.