CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Help Please--UDF compile (

xc November 28, 2005 16:37

Help Please--UDF compile
Hello All,

When I tried to bluid a UDF after adding the source file, it is said,

(system "copy C:\Fluent.Inc\fluent6.2.16\src\makefile_nt.udf libudf\ntx86\2d\makefile") 1 file(s) copied.


(chdir "libudf")()

(chdir "ntx86\2d")()

'nmake' is not recognized as an internal or external command, operable program or batch file.

What should I do? Where is the "nmake"?

Billions of thanks,


Alec Eiffel November 28, 2005 17:25

Re: Help Please--UDF compile
you need to install Microsoft Visual Studio. search forum for 'namke' for more info

xc November 28, 2005 18:07

Re: Help Please--UDF compile
I have Microsoft Visual Studio, and tried to set the correct environmental variables. Still I have the problem. Let me know if there is other possible reason. I am searching the whole forum too. Many thanks,


yoshida November 28, 2005 22:46

Re: Help Please--UDF compile
Have you restarted the system? In case of VC7 "nmake" is usually in "C:\program files\Microsoft visual studio .NET 2003\vc7\bin" so you have to add it to environmental variable "PATH" and restart Windows.

Mahesh Masurkar November 29, 2005 05:14

Re: Help Please--UDF compile
U need to install VC++ 6.0 or later and also check for environment variables. The list of these variables, u'll get it from Fluent url.

xc November 29, 2005 11:31

Re: Help Please--UDF compile
Thank all for your help. It is the problem of environment variables. Now the problem is solved.


MarcoFromParma December 2, 2005 11:52

Re: Help Please--UDF compile
I've tha same problem but I don't know how you resolved it. Could you send me some more information? I've Visual Studio and DevC++. Thx a lot! :)

xc December 2, 2005 13:34

Re: Help Please--UDF compile
Go to the Following the instructions, set the environment variables carefully and restart your pc. Hope it works


All times are GMT -4. The time now is 00:57.