CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   ERROR - invalid argument / not a number (

spepsicho May 31, 2006 03:29

ERROR - invalid argument / not a number
hi all

i'm running external aero simulation with a basic set-up (uncompressible air, stand. k-e ...).

the computation is ok and seems to CV normally. but at one point, without any DV in the residuals, i get this error message:

Error: > (greater-than) invalid argument (wrong type): not a number. Error Object: nan

i don't understand where does it come from and if it is linked to my model, since it's working properly at the beginning...

does anyone have an idea? is my file corrupted? i really need some info about that error.



Aidan May 31, 2006 06:16

Re: ERROR - invalid argument / not a number
this usually indicates a large or infinite number such as a division by zero. might occur in a UDF if you are using one

spepsicho May 31, 2006 06:43

Re: ERROR - invalid argument / not a number
I understand that some value is to big to be supported by the solver, but it's quite unclear why..

I don't use UDFs and especially, why would the case be OK for a quite long time and then crash like this without any apparent DV (which would clearly indicates increasing numbers) ??

I'm really stucked because I can't know what's the origin. If you have more details about the possible reasons, don't hesitate ;o))


Claud June 2, 2006 07:12

Re: ERROR - invalid argument / not a number
Maybe you should try to start your simulation a few iteration steps earlier before this error showed up (hope you use the autosave function). Then try to change one/some of your URF and start your iteration again. Sometimes it helps but I am also facing this problem and I don`t find the reason for that. Claud

Laurence Wallian November 4, 2009 03:33

I know your messages are old, but since I've just met this type of error, I think it can be usefull for anyone to know in what way it can occur : in my case, it's a mistake in the fluent journal file, I've defined an inlet with these lines :
/define/boundary-conditions/velocity-inlet INLET
no yes yes
no 0.1
no 0.0
; turbulent : I=0.0% L=0.0
no yes 0.0 0.0
the error must be : L=0.0% !!!! the solution is to write k=0.0 and eps=0.0 :
/define/boundary-conditions/velocity-inlet INLET
no yes yes
no 0.1
no 0.0
; no turbulent : k=0.0 eps=0.0
yes no 0.0 no 0.0

enigma June 22, 2010 20:22

I had the same problem, however, I found 2 solutions for this issue (might only work in my case, implicit density based simulation, single precision).

The described problem only occured when I ran a job with multiple cores (parallel). The message did not pop up when I ran the job in serial mode (on just one processor). Hence I ran a couple of iterations in serial mode, then switched back to parallel processing.

The second solution I found was to simply switch to double precision (hence the division by a value close to zero could be resolved).

Played around for quite a while with this, hope this will help others!

ach1505in June 23, 2010 07:13

Try reducing the CFL no., hopefully it will help...

ndabir October 29, 2011 16:11

I also had the same problem. very very high numbers (nan)

I just changed from single precision to double, and the problem was solved :))

thanks to enigma for the great advice.

by the way parallel settings does not contribute to this error.

All times are GMT -4. The time now is 16:57.