CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   problem with nozzle flow (

belinda June 27, 2006 07:12

problem with nozzle flow

I am running a jet through a converging nozzle at Ma=0.5 which enters a domain at atmospheric conditions. The problem is that when i change from first order implicit to second order implicit(segregated solver) the solution (T,p) gets unbounded towards the limits set in the solver. I tried setting the limits to more realistic values than the default but still the problem persists. After a while the solution blows up. I tried both the nita and default versions of the solver.

I use pressure inlet at the nozzle inlet and pressure outlet at the domain exit. Could the problem be due to none reflectiveness of the outlet condition? should the coupled solver give better results?

Thank you for your help and kind answers.

belinda June 27, 2006 07:39

Re: problem with nozzle flow
Whops, I mean of course *reflictive* boundary condition. I should also add that the residuals look ok until the final blow up. CFL is also restricted under 0.3 . decreasin the underrelaxation did not help either..

Rams June 27, 2006 08:26

Re: problem with nozzle flow
continue iterating with first order implicit,... for some more iterations,... and then after solution gets stabilized chage to second order implicit,....

reduce under relaxation factor for dentsity etc ,... and crry on

belinda June 27, 2006 08:36

Re: problem with nozzle flow
thanks for the advice. I tried this already but there was no change in the trend that after some 2000 time steps the solution blows up.

Radwa July 2, 2006 14:08

Re: problem with nozzle flow
I dont know whats the reflective boundary condition, but did u try using the outlet vent boundary condition

Dr Hasan Khan July 12, 2006 17:42

Re: problem with nozzle flow
Hello Belinda,

I have solved atleast 100 cases with higher mach numbers for converging/convering-diverging nozzles. Your inlet condition has to be a pressure inlet. Outlet as pressure outlet.

I don't know your geometry exactly, otherwise I would have guided you more.


All times are GMT -4. The time now is 07:49.