CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   error while compiling a udf (

rahul August 10, 2006 00:20

error while compiling a udf

I am trying to compile a udf to use a dynamic mesh. I am geting following error message, i did the same way as given in udf manual. When i try to build this udf this msg is displayed.

1 file(s) copied. (system "copy C:\Fluent.Inc\fluent6.2.16\src\makefile_nt.udf libudf2\ntx86\3ddp\makefile") 1 file(s) copied. 0 (chdir "libudf2")() (chdir "ntx86\3ddp")() 'nmake' is not recognized as an internal or external command, operable program or batch file. 'nmake' is not recognized as an internal or external command, operable program or batch file.

could somebody let me know how i should overcome this problem.

thank you


Albert Franco August 10, 2006 02:38

Re: error while compiling a udf
ok I send you the instructions:

download (all are free versions):


then check and correct the following paths (start->my computer->system->advanced->environment variables):

LIB = C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\ATLMFC\LIB;C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\LIB;C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\PlatformSDK\lib\prerelease;C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\PlatformSDK\lib;C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\lib;C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\Lib

INCLUDE = C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\ATLMFC\INCLUDE;C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\INCLUDE;C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\PlatformSDK\include\prerelease;C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\PlatformSDK\include;C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\include;C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\include\;C:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\include

PATH = C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\Bin;C:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\bin;C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\IDE;C:\Program Files\Common Files\Microsoft Shared\VSA\7.1\VsaEnv;c:\documents and settings\ww\\ntbin\ntx86

After all this look for nmake file in your computer and atach the path of the directory in the list.

This instructions are what I followed when I was in your situation so I help it can help you.



Blas August 17, 2006 16:30

Re: error while compiling a udf
Hi Rahul/albert I'm experiencing the same problem. Do I have to install/run these files once downloaded? Also, I looked for the nmake file in my computer but the search engine did not find it, could you help me out? Thanks Blas

Albert F. August 18, 2006 02:40

Re: error while compiling a udf
As far as I'm concerned you have to install those programes unless you have installed another programe that is also compatible but I only can suggest what I've experienced...

Refering to the nmake file please, make sure if you have the following directory, in my computer is here.

C:\Program Files\Microsoft.NET\SDK\v1.1\Bin

Blas August 18, 2006 06:37

Re: error while compiling a udf
Hi Albert, thanks for your response. I only have C:\Program Files\Microsoft.NET\primary interop assemblies but not what you describe. Maybe it's created when I install the downloaded files?

Albert F. August 18, 2006 07:24

Re: error while compiling a udf
Yes, I think that this paths vary depending on your instalation, but I think the path I send you was the default one. Anyway, try to run search engine in the directory and nmake.exe should appears. If it doesn't I don't know what to do because the steps I posted were the onces I followed.

Good luck and tell me if all is solved!


Blas August 18, 2006 13:14

Re: error while compiling a udf
I found the nmake file now, but which path do I need to attach to this file and how? Thanks again Blas

Albert F. August 21, 2006 02:30

Re: error while compiling a udf
At the same panel of enviroment settings you have different options. One is path. If you select this option a window will appear and you have to copy the direction of the folder where is nmake file.

Blas August 22, 2006 08:00

Re: error while compiling a udf
Hi albert, I could solve the nmake error and apparently I can now compile but I have trouble with loading the compiled file though, as I keep getting the following error:

Deleted old libudf\ntx86\2d\libudf.dll The system cannot find the specified file.

1 file copied. (system "copy D:\Fluent.Inc\fluent6.2.16\src\makefile_nt.udf libudf\ntx86\2d\makefile") 1 file copied. 0 (chdir "libudf")() (chdir "ntx86\2d")()

Done. "d:/"

Opening library "libudf"... Error: open_udf_library: The system cannot find the specified file.

Error Object: ()

Any idea of what might be happening? Thanks

Albert F. August 22, 2006 08:13

Re: error while compiling a udf
I don't know if it will help you but you could try a couple of things:

Create a working directory with the following carachteristics:

- Only .cas file and .c file inside the dictory

- The name of the udf cannot contain strange carachters like '?*/.!...

- Be sure that the name of the working directory and the previous ones does not contain spaces. I mean call myworkingdirectory instead of my working directory

If all is correct, you modified path and includes in enviroment settings and .net framework 1.1 is installed should works well.

When I was in your situation I followed the instructions I posted a few messages above and now all is working fine. I hope it help you

Blas August 30, 2006 08:33

Re: error while compiling a udf
Hi Albert Finally I had to install Ms Visual Studio 6.0 as my C compiler and everything is working properly now. Thanks for your help anyway. Regards

All times are GMT -4. The time now is 06:16.