CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Veeery sloooow convergence (

JB December 4, 2006 05:10

Veeery sloooow convergence
Hello everyone,

I launched a calculation on friday evening, and when I came back this morning... Surprise! ONE iteration done...

From my (little) experience with fluent, if the model is not set up properly, the solution diverges and an error message is displayed.

I don't think it's a CPU/RAM problem either, as my model is about 10,000,000 elements, for a linux PC, 2*dual proc, 16Gb RAM. (i solve the energy equation).

Any clue? Thanks for your help /jb

Charles December 4, 2006 05:49

Re: Veeery sloooow convergence
It should be pretty obvious if it has run out of RAM and is disk-swapping. 10e6 cells, energy equation, turbulence model (?), if you are using double precision I would not be surprised if you are out of RAM.

JB December 4, 2006 07:17

Re: Veeery sloooow convergence
no double precision, no disk swapping... when I do a ps -aux, it looks like fluent only uses 50% of RAM. I checked (again) my mesh, BCs, etc... I rebooted the computer... same problem.

succinct December 4, 2006 07:23

Re: Veeery sloooow convergence
Since you have a dual process think of running in parallel

fluent 3d -pnet -t2

JB December 4, 2006 07:26

Re: Veeery sloooow convergence
thanks for your answer, but I'm already running my calculation in parallel

Riaan December 5, 2006 11:34

Re: Veeery sloooow convergence
Its a bug, my cluster does the same thing as well. Reset, and reload.

JB December 5, 2006 11:57

Re: Veeery sloooow convergence
Thanks Ryan.

Yes, I talked with a Fluent guy that told me that It might come from a too large number of faces inclueded in my non-conformal interfaces. Any kind of warning would have been appreciated :/

anyway... i'm meshing a new model without non-conformal interfaces, in order to check if this realy was the problem!

JB December 7, 2006 05:35

Re: Veeery sloooow convergence --> NOT SOLVED YET

My pb is not fixed yet, but I have new info for anyone willing to help.

I thought I fixed the original pb by rermoving any non-conformal interface in my model. I ran the new model without any problem, until it crashed due to our stupid crappy network. Anyway.. I launched again the calculation before leaving the office yesterday, and this morning, fluent was still stucked to the 1st iteration!! (same pb as when launching the model with non-conformal interfaces). I was about to kill myself, staring at the empty fluent monitors, when suddently, the calculation started for real!!

Now everything is working fine, but why the hell did Fluent had to wait for me move the mouse to launch the calculation for real??????? I'm very confused... I lost about 3 days of work in our project (so far :/) for nothing.

Any clue?

babak December 7, 2006 15:18

Re: Veeery sloooow convergence
hi. your elements are very high.increase your interval size

JB December 7, 2006 17:15

Re: Veeery sloooow convergence
What do u mean?? I don't get it

babak December 8, 2006 15:31

Re: Veeery sloooow convergence
it means that you should meshing your geometry with high interval size(in mesh object after define meshing type you must define interval size )if you decrease this value , your elements will be very much .

JB December 8, 2006 15:41

Re: Veeery sloooow convergence
dude, I already have a f#cking coarse mesh!!.. of course less elements MIGHT help, but unfortunately i'm afraid this is not an option if I want to keep a good accuracy level.

All times are GMT -4. The time now is 17:04.