CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   platform (

Andrew December 12, 2006 11:58

I am running an Intel Xeon 64 bit processor with RedHat EL4. When I run fluent_arch1.0 the responce is: lnamd64.

I am guessing this is wrong. Is there a way I can force fluent to use x86, if this is what I am supposed to be using? I can use export FLUENT_ARCH lnx86

which seems to do the job temporarilly. However, when using this option my UDF's don't work. I know that the .c file works correctly, but the set up of fluent on my PC must be wrong.

Any help?

hugo December 12, 2006 12:32

Re: platform

If you fluent_arch and the responce is Inamd64 is because you need to use the Fluent64, you can't use Fluent x86 in this arch because you have a 64 bit processor.

Doy you have the 64 bit Fluent distribution to install?

good luck

Andrew December 13, 2006 06:03

Re: platform
On the disk I have it says

Intel Pentium (x86) and AMD Opteron (x86_64)

I can run fluent in lnamd24 and x86 on my PC perfectly well for simple problems. However, when I come to compile UDFs I get an error message which I think is related to the fact that fluent can't find the libraries for a particular machine architecture. When I run the same UDF's on an AMD64 machine I do not get the error.

hugo December 13, 2006 09:17

Re: platform

Ok. you have the Fluent distribution for 64 bit processors. The correct is to use this distribution in both machines; the AMD64 and Intel Xeon 64 and that would work well.

I think it's doesn't matter if you run the 64 bit distribution on Intel Xeon 64 or AMD64.


Is The problem with the Inamd64 on Intel Xeon 64? or Are you trying to use the Inamd64 on x86 proccesor?

If you have problem with the first question, tell me the error message and maybe I can help you.

good luck

Andrew December 14, 2006 06:48

Re: platform
This is a bit silly, but I had another go at compliling the UDF to get the error message to post here and I can't get the probelm to occur again. Everything is working perfectly. Thanks for help though.

All times are GMT -4. The time now is 13:44.