CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Error: invalid argument [1]: improper list (

Ralf Schmidt April 10, 2007 03:03

Error: invalid argument [1]: improper list

I have a very large mesh (ab. 2.000.000 cells) with k-w, no energy eq. that runs not very stable. However, it runs ;)

But, when I interupt iterating, save the file, take a look at the results and start again, Fluent gives following message:

Error: GENERAL-CAR-CDR: invalid argument [1]: improper list

Error Object: #f

When I read case and data again, the iteration works fine... until I turn on energy eq. or another turbulence model. Once, i run it laminar, and when i turn on any turb. model, the error message came...

So any help is highly appreciated!!!


Phil April 10, 2007 17:08

Re: Error: invalid argument [1]: improper list
If I am understanding you properly then I occasionally get this problem. I just re-read case and data then forget about it. Has never caused me any problems.

Ralf Schmidt April 11, 2007 13:29

Re: Error: invalid argument [1]: improper list

thanks for answer, but it didn't worked. Could it be because of the error message fluend gives, when it reades the grid:

Warning: Number of nodes read (1057672) does not match number referenced (1056748).

Resetting counter to match the number referenced.

Ther is somewere a volume, that has only one face meshed, and that is not exported - could that be the reason??


bashu April 11, 2007 14:35

Re: Error: invalid argument [1]: improper list
Have you defined any monitors?

Ralf Schmidt April 12, 2007 02:29

Re: Error: invalid argument [1]: improper list
yes and now. I defined some, but even when I turn them off the error appears

bashu April 12, 2007 08:28

Re: Error: invalid argument [1]: improper list
When I define the monitors and then change some paramters the monitor definitions sometimes get messed up. It looks like you don't have similar situation.

Ralf Schmidt April 12, 2007 12:33

Re: Error: invalid argument [1]: improper list

I thing the problem is solved, at least it didn't appear any more.

I don't know, what is different - i worked on the grid again and made it really good quality mesh (ab 95% of the cells have a skewness below 0.2 :)

I read the mesh again, iterated, saved, turned on energy eq. iterated again and the error appears again :(

Than I read the file again, iterated untill convergence, turned on energy eq. and continued to iterate was no problem!! Until now, the file runs very fine!

So, what ever the problem of fluent is - it seems to me to be a little random. However, hoping that "&*'?"$ error will not appear anymore!


gr135 May 29, 2017 05:26


I happen to get the same error in fluent when I try to load MHD add-on module after selecting non-premixed combustion.

Can someone point out to why is it happening?

All times are GMT -4. The time now is 10:44.