CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Exporting ICEM Tetra Grid to Fluent with Hexa-Core (

Tim August 28, 2007 04:48

Exporting ICEM Tetra Grid to Fluent with Hexa-Core
I've just recently started using ICEM Tetra/Prism and seem to be having problems getting my mesh files exported into Fluent. I import the geometry into ICEM in IGES format, tidy it up and name all the parts, mesh using the Octree method and then apply a hexa-core to the volume mesh using the Delaunay approach. Smooth the mesh, check it for all errors and possible problems and then export in Fluent_V6 format .msh file. The only possible problems that I'm not sure about are with Delaunay violations.

The problem is that then when I try to read the grid into Fluent I get a read error. I've tried ACSII and binary formats and neither work. I've also found that importing the grid with a pure Tetra mesh (i.e. no hex's) does work. So I'm thinking that the problem is how Fluent interprets the Hexa-Core mesh topology.

The exact error messeage upon reading into Fluent is as follows:

> Reading "C:\Documents and Settings\tim\Desktop\Sample-Assembly6.msh"

253326 nodes.

675151 mixed cells, zone 73.

Error: read: face 1471627, zone 74.

Reading Faces: failed while reading section 13.

Clearing partially read grid.

Error: Read aborted dut to critical error.

Error Object: ()

Error: Error reading "C:\Documents and Settings\tim\Desktop\Sample-Assembly6.msh".

Error Object: #f

If anyone has any ideas as to what I can do to correct this problem then any assitance would be very much appreciated.

Thanks, Tim

Joe August 28, 2007 17:44

Re: Exporting ICEM Tetra Grid to Fluent with Hexa-
I use icemcfd as my mesher. I dont recall running into this problem. Have you tried a trivial test case: Simple block, tet meshed, then hexa-cored ... try that. Fluent does support full hybrid meshes.

Tim August 30, 2007 07:16

Re: Exporting ICEM Tetra Grid to Fluent with Hexa-
For anyone else that has this problem, I have obtained the solution from Ansys Support. Apparently ICEM 11.0 has a bug within it's Fluent translator for Windows operating systems that only affects hexa-core meshes. If you downloaded ICEM from the Ansys customer portal recently then the correct translator should be a part of the bundle, but because I installed ICEM from installation disks, this contained the original defective translator. So if you have a problem similar to what I had, then your best bet is to contact Ansys support who should be able to provide you with the correct translator.

For all that contributed to this post, thanks anyway for the input Joe.

All times are GMT -4. The time now is 13:28.