CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Problems in lauching FLUENT (

Lourival December 17, 2007 15:10

Problems in lauching FLUENT
Dear all,

I installed Fluent in one computer named ROBOCOP (Master) and I want to use two others as NODES (GHOST-RIDER and DARTH-VADER).

So I type on the cmd the following command:

fluent 3d -t4 -pethernet -mpi=mpich2 -cnf=e:\hosts.txt -path\\robocop\

As you probably know the Environmental Variables are set on the right way and the host file is as follow:

robocop robocop ghost-rider darth-vader

If I take of darth-vader from the host file I have NO trouble at all and Fluent runs OK. But if I put the darth-vader in the host file I got the following error:

Checking the status of SMPD for MPICH2 on the local machine ... smpd running on robocop

job aborted: rank: node: exit code[: error message] 0: robocop: 13 1: robocop: 13 2: darth-vader: 13: Fatal error in MPI_Barrier: Internal MPI error!, error stack: MPI_Barrier(406)..........................: MPI_Barrier(MPI_COMM_WORLD) failed MPIR_Barrier(76)..........................: MPIC_Sendrecv(161)........................: MPIC_Wait(321)............................: MPIDI_CH3I_Progress(161)..................: handle_sock_op failed MPIDI_CH3I_Progress_handle_sock_event(193): MPIDI_CH3U_Handle_recv_pkt(1320)..........: received unknown packet type (type=926234675) 3: darth-vader: 13

with the host file as:

robocop robocop darth-vader darth-vader

Another interesting thing, if I launch the Fluent via the Launcher program but instead of clicking on the LAUCNCH buttom I click on the CHECK Buttom I got this:

Fluent 6.3.26 supported MPICH2 version: 1.0.3 (Redistributed by Fluent Inc. BUILD May 4 2006 15:36:14)

Validating user credentials: SUCCESS Checking MPICH2 SMPD on robocop: 1.0.3 (Redistributed by Fluent Inc. BUILD May 4 2006 15:36:14) Checking MPICH2 SMPD on robocop: 1.0.3 (Redistributed by Fluent Inc. BUILD May 4 2006 15:36:14) Checking MPICH2 SMPD on darth-vader: 1.0.3 (Redistributed by Fluent Inc. BUILD May 4 2006 15:36:14) Checking MPICH2 SMPD on darth-vader: 1.0.3 (Redistributed by Fluent Inc. BUILD May 4 2006 15:36:14)

**** The configuration has been checked, and the command for submit is as follows: \\robocop\\ntbin\ntx86\fluent.exe 3d -r6.3.26 -t4 -mpi=mpich2 -cnf="e:\hosts.txt" -antx86

Does some one know something about it??


rj January 10, 2008 12:33

Re: Problems in lauching FLUENT
It looks like some network issue on darth-vader. You may try the following: 1. retart darth-vader to see if it helps? 2. reinstall the MPICH2 package on darth-vader to see if it helps? 3. restart the SMPD daemon on darth-vader.

In addition, you may need to compare the differences between the two computers, ghost-rider and darth-vader.

Hope it helps. Otherwise, you may need to try the HP-MPI, which is coming with FLUENT6.3.33 and newer versions.

Lourival January 14, 2008 12:01

Re: Problems in lauching FLUENT
Dear rj,

I did everything possible including all the guesses that you send and nothing worked. But I find a way to work around and there is two issues that I would like to share:

1) On the darth-vader I installed an image from another computer (mandrake) and when the image was created the host name on the TCP/IP of the darth-vader was still mandrake instead of darth-vader as we changed. The most interesting part is that the darth-vader was on the network and no conflicts was detected, except that the ping on the darth-vader to darth-vader and to mandrake resulted in the same IP number....

2) The issue (1) was corrected and the problem was still the same so I uninstalled the MPICH pack from FLuent and installed the MPICH2 from the Argonne Lab. I tested with the examples (e.g cpi.exe) and everething was OK, after I installed the Fluent MPICH pack without uninstalling the MPICH2 from Argonne and Finally it was able to connect and run the simulation.

It seems that the MPICH Fluent Pack is missing something that is on the MPICH2 pack, maybe some .dll

Thanks for your attention


rj January 16, 2008 17:48

Re: Problems in lauching FLUENT
If really some DLL is missed, it doesn't explain why other machines work. Actually, you didn't reinstall and test the FLUENT MPICH2 package after you corrected the IP error.

Anyway, I'm glad to know it works for you!

All times are GMT -4. The time now is 23:41.