CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Fluent & Ubuntu 7.1 (

Charles March 13, 2008 12:33

Fluent & Ubuntu 7.1
Has anybody out there had any luck running Fluent 6.3 under 64-bit Ubuntu 7.1? There seems to be some incompatibility. I have had good success with Fedora Core 4 and 6, but there are various good reasons (such as all hardware being supported) why I would like to keep this particular computer on Ubuntu.

Will Humber March 13, 2008 21:43

Re: Fluent & Ubuntu 7.1
I've tried without any success, but if you manage to get it up and running please either post your method here or e-mail me at . I have very similar concerns with regard to hardware.

Vinod Dhiman March 14, 2008 03:45

Re: Fluent & Ubuntu 7.1
No, you cannot run Fluent on any other linux systems except Red Hat, Fedora, and Suse. Fluent is not designed for that.

Charles March 14, 2008 06:45

Re: Fluent & Ubuntu 7.1
It may not be designed for that, but it looks like it is up & running now. The annoying thing is that I'm not exactly sure how! Since it last didn't work, I've done the following:

1. Installed OpenFOAM, although I am convinced this has nothing to do with it, the info is just for completeness.

2. Used the Synaptic package manager and installed a bunch of stuff, including the sshd service and everything that looked like a glibc or libc package, including the 32-bit libs.

3. Configured passwordless ssh on the system.

Anyway, it works. My guess is that step 2) is what made the difference.

Fábio Saltara March 19, 2008 14:24

Re: Fluent & Ubuntu 7.1
I successfully installed Fluent 6.3 on UBUNTU 7.10 X86_64 "Gutsy". The only problem was that to run Gambit you need to install Libmotif. You have to search the package with Synaptics. Maybe in some systems you have this problem with Fluent, too. I can recall that to run Fluent on Opensuse 10.2 I needed to install Openmotif, the rpm equivalent to Libmotif.

Running Fluent, the only problem is that sometimes, when you click a button, you can't sellect an option with the mouse. You must use the keybord arrow keys to scroll through options. But turning off the compiz visual effects solved this problem.

Ravi Ramalho March 31, 2008 13:56

Re: Fluent & Ubuntu 7.1
Fábio, what did do to make fluent run properly on ubuntu 7.10? I'm having some problems: if I try to run as a user, it throws an error related to 'domainname' param. I can't run using sudo because hasn't set the environment variables. I found something on the internet about changing the script (sh to bash) to run on ubuntu. I have less error messages now, but sill can't make it to run. Can you help, please? Thanks in advance.

Ravi Ramalho April 1, 2008 00:13

Re: Fluent & Ubuntu 7.1
Guys, finally made it. The deal is install package libmotif-dev and libstdc++5 using synaptic. Thus edit the scripts (e.g. .../Fluent.Inc/bin/fluent and ...Fluent.Inc/bin/gambit) changing the first line. Original first line: #!/bin/sh New first line: #!/bin/bash Now I have Fluent 6.3 and Gambit 2.4.6 fully functional on Ubuntu 7.10.

Hope it help you too, guys.

All times are GMT -4. The time now is 02:01.