CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   how to use the utility'tpoly' ? (

jimmy October 29, 2008 03:29

how to use the utility'tpoly' ?
hi everyone!I am trying to simulate a SCR model using fluent 6.3 solver in parallel sovler,i use the tet/hybrid's hexcore(TGrid)to create volume mesh in gambit,after exporting the *.mesh,let it be readed in fluent,appearing the following error report: warning:hex-core mesh should be processed by utility tool 'tpoly' before reading in parallel warning:users are strongly recommended to convert the transitioanl cells into polyhedral ones using the provided utility tool 'toply' for hexcore mesh!

unable to read the cmd header on the pmi context,underfined dynamic error code. recevied suspend command for a pmi context that doesn't exist:unmathed id=1

recevied suspend command for a pmi context that doesn't exist:unmathed id=0

999999(..\..\src\mpsystem.c@1123):mpt_read:failed: errno=10054 999999:mpt_read:error:read failed trying to read 4bytes:invalid argument unable to read the cmd header on the pmi context,underfined dynamic error code. job aborted: rank:node:exit code[:error message] 0:computer:123 1:computer:-1073741819:process 1 exited without calling finalize 2:computer:-1073741819:process 2 exited without calling finalize 3:computer:-1073741819:process 3 exited without calling finalize the parallel fluent process could not be started

according to the error report,i consult the fluent help text,it says that "To convert a file using the tpoly filter, before starting FLUENT, type the following: utility tpoly input_filename output_filename"i try it in fluent,fluent point out that it's a invalid command ,pls help to tell me what's the problem? thanks a lot!

mAx October 29, 2008 03:42

Re: how to use the utility'tpoly' ?
let say your mesh is named as test.msh

Open a shell, and type:

> utility tpoly test.msh test_tpoly.msh

where test_tpoly.msh will be the result of your mesh conversion

That's all

jimmy October 29, 2008 04:25

Re: how to use the utility'tpoly' ?
i try it like what you said(not in parallel),but the fluent still says that it's invalid(utility).i even type the command in gambit after read in the original *.msh,gambit says that it's unknown command.there is nothing i can do…………

mAx October 29, 2008 04:34

Re: how to use the utility'tpoly' ?
go and look if you have the executable utility under fluent\utility

If it is, then re-set your environment variables (by the way under which OS are your working?)

jimmy October 29, 2008 04:49

Re: how to use the utility'tpoly' ?
i have 'tpoly1.0' under fluent\utility,and my working is under windows XP x64 edition.i don't know how to re-set my environment variables and which variable should be re-set,can you teach me?thanks again!

mAx October 29, 2008 05:11

Re: how to use the utility'tpoly' ?
In Start, look for Fluent.Inc, and it should be something like "Set Environment"

Try also to launch fluent via Command Window

mr-fluent October 29, 2008 20:28

Re: how to use the utility'tpoly' ?
set the path to that utility.

Or give the full path in the command itself.

calling tpoly is done by

utility tpoly arguements ...

jimmy October 29, 2008 21:28

Re: how to use the utility'tpoly' ?
i type the command in full path like that:"> c:\\utility\tpoly1.0\win64\tp100 test.msh test_tpoly.msh",fluent report that"invalid command [c:\\utility poly1.0\win64 p100]".i also re-set my environment in start\,still not you-all have anyother suggestion? in addition,it is said that the 'Tgrid' can also be used like utility tpoly to convert the transitional hexahedral cells into polyhedra,my question is how to use the 'tgrid'?thank you

mr-fluent October 29, 2008 22:20

Re: how to use the utility'tpoly' ?
i think the mistake that you are making is giving the path to utility folder but NOT to the bin folder where the utility should be there.

For me utility is in folder


So I shall run it as

/home/Fluent.Inc/bin/utility tpoly .....

If you do not see utility command in your Fluent.Inc/bin/ folder than you got to check your installation.

jimmy October 29, 2008 23:04

Re: how to use the utility'tpoly' ?
yes,you are right,there is no bin folder in my\,does it mean that i should re-installation the fluent?my software is genuine,so i think it should not appear this problem,what should i do if i still can not find the bin folder after re-installation?do you have any idea?

jimmy October 29, 2008 23:15

Re: how to use the utility'tpoly' ?
i find there are two 'utility.exe' in the path E:\Fluent.Inc\ntbin\ntx86\utility.exe and E:\Fluent.Inc\ntbin\win64\utility.exe,can these"utility" work?

mr-fluent October 29, 2008 23:55

Re: how to use the utility'tpoly' ?
i checked my windows machine and my utility is at


so this path should work, you could in fact create a batch file for it.

But the best is to set environment for fluent as earlier suggested.

jimmy October 30, 2008 00:49

Re: how to use the utility'tpoly' ?
i re-set environment for fluent,windouws says the environment has been successfully modified,then i tpye the 'tpoly' command in fluent,but it not work,i am at a loss,but thank you all the same,i don't known whether anyother people encounter my problem,if you have lastest news about it, pls tell me,i am deeply grateful!

mr-fluent October 30, 2008 00:56

Re: how to use the utility'tpoly' ?
utility -h

should list all the available utilities, if you do not see tploy in the list that means either you are working with wrong version of fluent or something wrong with your utility version.

jimmy October 30, 2008 03:43

Re: how to use the utility'tpoly' ?
i try it in fluent as you say,but i do not see the tpoly in the list,even do not see the list which should show all the available utilities! as the following: "> utility -h invalid command [utility]" my fluent version is 6.3,i think it's the lastest version,why i encounter these problem,is it normally?

mr-fluent October 30, 2008 04:22

Re: how to use the utility'tpoly' ?
there is something seriously wrong with your path set up, if i were you i could go to the folder where utility.exe is and run it like by


specifically asking it to run from the folder i am in. There there is no issues of path variable.

Now if i run it from the folder where utility is there are only two possible outcomes.

1. It works -> set the path of machine , or check it

2. does not work -> reinstall fluent.

jimmy October 30, 2008 21:30

Re: how to use the utility'tpoly' ?
i chech my software installtion path,my utility is in the path of 'E:\Fluent.Inc\ntbin\ntx86\utility'.as you said, i open a fluent shell,running the utility from the folder where the utility is in,as the following:"> ./",then fluent output the error report:"Error: Journal file "" not found. Error Object: #f" dose this case mean that it does not work and i have to reinstall fluent?i iterate the work on other people's computer,it still have the same problem.i will try to reinstall my fluent,but what should i do if it still does not work after reintalltion?

mr-fluent October 30, 2008 22:05

Re: how to use the utility'tpoly' ?
i went to my linux installations folder and run the utility by

./utility -h

it does work. So it seems your is installation problem.

I noticed that your installation is in E partition. Usually with fluent if the installation is default location everything works fine without any problems. Not sure your problems are anyway linked to E: partition or not. Just a thought.

jimmy October 30, 2008 22:30

Re: how to use the utility'tpoly' ?
my partner's fluent installtion is default location,i try it on his computer just now,typing the command:">./utility -h",it still have the same error report:"Error: Journal file "utility" not found. Error Object: #f",it seems that it may be also not the installtion problem,can you do me a favor of showing me a intercepting picture about your running case?i just want to see the ideal running process,thank you

mr-fluent October 31, 2008 00:13

Re: how to use the utility'tpoly' ?
here is an output of a very small mesh converted:

: utility tpoly circbend01.msh testout.msh Starting /home/Fluent.Inc/utility/tpoly1.1/lnamd64/tpoly.1.1.0 circbend01.msh testout.msh Unadopt kids faces Reading the mesh file... Read 4903 nodes, 49732 faces Replacing parent edges... Replacing parent faces... Writing the mesh file... done

The important line is:

Starting /home/Fluent.Inc/utility/tpoly1.1/lnamd64/tpoly.1.1.0

All times are GMT -4. The time now is 16:33.