CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   error running fluent 64 bit in kubuntu 8.1064-bit (

Anastasios Georgoulas December 20, 2008 04:44

error running fluent 64 bit in kubuntu 8.1064-bit
Dear all,

I try to run fluent 6.3.26 64 bit version in kubuntu 8.10 64bit and i get the following message ageorg@ageorg-desktop:~/Fluent.Inc/bin$ ./fluent /home/ageorg/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 /home/ageorg/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: domainname: not found /home/ageorg/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3 -f fluent (fluent " -r6.3.26 -path/home/ageorg/Fluent.Inc") /home/ageorg/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3: error while loading shared libraries: wrong ELF class: ELFCLASS32

Can anybody please provide me with some guidelines? What should i do?

Thanks very much in advance


wlh December 20, 2008 05:32

Re: error running fluent 64 bit in kubuntu 8.1064-
maybe you should intall a vc++, which should be supported by 64 bit.

Anastasios Georgoulas December 20, 2008 06:45

Re: error running fluent 64 bit in kubuntu 8.1064-
Thanks very much!

i will try to do that although a dont know exactly what is a vc++. I think i could find out through a google searh.


Stefano Rolfo January 14, 2009 10:55

Re: error running fluent 64 bit in kubuntu 8.1064-
I had the same problem under SUSE11.1. I solved simply installing the library libstdc++33. I don't know but may be you have the libstdc++43 that provides Same problem also for Gambit with the library openmotif22-libs (in opensuse is installed 2.3).

Anastasios Georgoulas January 15, 2009 02:21

Re: error running fluent 64 bit in kubuntu 8.1064-
thanks for the reply i solved the problem with the same way

anyway thanks again.

isabel November 10, 2010 04:50

Hello everybody,

When I try to execute Fluent in ubuntu 64 bits, I have the following error:
isabel@isabel:~/Escritorio$ fluent 3d
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: /sbin/lspci: not found
/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3 -f fluent (fluent "3d -alnx86 -r6.3.26 -path/home/isabel/Fluent.Inc")
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4715: /home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3: not found

Does anybody know why?

isabel November 10, 2010 04:52

Hello everybody,

When I try to run Fluent in ubuntu 64 bits, I have the following error:

isabel@isabel:~/Escritorio$ fluent 3d
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 3d
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: /sbin/lspci: not found
/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3 -f fluent (fluent "3d -alnx86 -r6.3.26 -path/home/isabel/Fluent.Inc")
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4715: /home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3: not found

It gives error about not found cortex.3.7.3, but I really have that file. Does anybody know what is happening?

vinerm November 10, 2010 10:35

Fedora and SuSE
When it comes to Linux, Fluent can only be run on either Red Hat, including Fedora or SuSE.

isabel November 10, 2010 13:26

Hello vinerm,

Sorry but I do not know what Red Hat, Fedora and SuSE means.I will tell you the details of my problem:

I succesfully installed Fluent in my 32 bits ubuntu. When I execute Fluent I obtain this message:

/isabel@isabel-desktop:~/OpenFOAM/isabel-1.5/applications/solvers/mono52$ fluent
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: domainname: not found
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: /sbin/lspci: not found
/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3 -f fluent (fluent " -alnx86 -r6.3.26 -path/home/isabel/Fluent.Inc")

And Fluent runs Ok.
Recently I changed to 64 bits ubuntu, I installed Fluent but when I try to execute it gives the following error:

isabel@isabel:~$ fluent
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: /sbin/lspci: not found
/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3 -f fluent (fluent " -alnx86 -r6.3.26 -path/home/isabel/Fluent.Inc")
/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent: 4715: /home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3: not found

The strange thing is that the file cortex.3.7.3 does exist and I do have it in "/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3"

vinerm November 11, 2010 10:14

Is Fluent you installed on 64 bit machine a 64 bit version? That could be the issue. We use 64 bit machines and in their path, x86 is always replaced by x86_64.

isabel November 11, 2010 10:58

This Fluent works Ok in linux 32 bits version, so I think it is not a 64 bits version.
Can I do something to install it in the 64 bits version of linux?

lift86 February 9, 2011 07:21

I installed fluent but when I launch it gives me the following errors. I tried to install the library libstdc + +33, butcan not find it . What can I do?

/home/gir/Scrivania/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
/home/gir/Scrivania/Fluent.Inc/fluent6.3.26/bin/fluent: 4677: /sbin/lspci: not found
/home/gir/Scrivania/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3 -f fluent (fluent " -alnx86 -r6.3.26 -path/home/gir/Scrivania/Fluent.Inc")
/home/gir/Scrivania/Fluent.Inc/fluent6.3.26/bin/fluent: 4715: /home/gir/Scrivania/Fluent.Inc/fluent6.3.26/cortex/lnx86/cortex.3.7.3: not found

isabel February 10, 2011 04:12

Hello lift86,

What version of Fluent are you installing, 32 bits or 64 bits?
And what version is your linux, 32 bits or 64 bits?

lift86 February 10, 2011 07:56

HEllo Isabel,
fluent is 64 bits and my prcessor is 64 bits

DoHander February 10, 2011 08:45


Have you searched the Debian repositories ? They have a lot of stuff (binary compaible with Ubuntu), you may have a chance to find your libstdc++ library version.

Try to use the Ubuntu IRC chat on freenode, there are a lot of smart guys there, just ask about finding the desired library and where to find it.


isabel February 10, 2011 09:39

Ok, Dohander. But probably my problem is because I am trying to install a 32 bits fluent into a 64 bits ubuntu.

DoHander February 10, 2011 11:04

Sorry my message was for lift86, my bad that I didn't mentioned this :).

In your case, yes, this is the problem - however on a 64 bits machine you can install, if you want, a 32 bits Linux. You can create a separate partition on which you can install Ubuntu 32 bits and your 32 bits Fluent version.

The ideal solution will be to install Fluent 64 bits on your current machine.


isabel February 17, 2011 13:57

Hello everybody,

I have installed Fluent 64 bits in my ubuntu 64 bits, but now I have the following problem:

/home/isabel/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3 -f fluent (fluent " -alnamd64 -r6.3.26 -path/home/isabel/Fluent.Inc")
/home/isabel/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3: error while loading shared libraries: wrong ELF class: ELFCLASS32

So I have typed the following command:
sudo apt-get install libstdc++5
And I had the error It could not be found the packet libstdc++5

If I type locate, I have the following:


Is the problem that I should have the library in /usr/lib/ instead

isabel March 9, 2011 04:54

If I type “ldd cortex.3.7.3” in my Fluent 32 bits with Ubuntu 32 bits I obtain this information:

isabel@isabel-desktop:~/Fluent.Inc/fluent6.3.26/cortex/lnx86$ ldd cortex.3.7.3 => (0xb7715000) => /lib/tls/i686/cmov/ (0xb76e4000) => not found => /lib/tls/i686/cmov/ (0xb76df000) => /usr/lib/ (0xb768c000) => /usr/lib/ (0xb767c000) => /usr/lib/ (0xb758d000) => not found => /lib/tls/i686/cmov/ (0xb7566000) => /home/isabel/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/lib/ (0xb7559000) => /lib/tls/i686/cmov/ (0xb73f6000)
/lib/ (0xb7716000) => /usr/lib/ (0xb73ed000) => /usr/lib/ (0xb73e8000) => /usr/lib/ (0xb73ce000) => /usr/lib/ (0xb73b6000) => /lib/ (0xb73b1000) => /usr/lib/ (0xb73ac000)

As you can see, the library “” is not found, but Fluent runs Ok.

Nevertheless, in my Fluent 64 bits in Ubuntu 64 bits, Fluent do not run without that library.
Does anybody know what I can do?

villager July 5, 2011 15:08

Yes, maybe I'll be able to help you. On the other hand, I manage with it on Ubuntu 10.10 (Maverick). I've just needed to work on Fluent+Ubuntu myself, and looking for solution of this problem, I've met this page.

First, add to yours ~/.bashrc following lines:

export FLUENT_ARCH=lnamd64
export FLUENT_INC=~/Fluent/Fluent.Inc
export FLUENT_LICENSE_FILE=$FLUENT_INC/license/license.dat
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/villager/Fluent/Fluent.Inc/fluent6.3.26/lnamd64/syslib:/home/villager/Fluent/Fluent.Inc/lib3.0/lnamd64

Note, that I had my Fluent.Inc in /home/villager/Fluent. You have it in some other dir.

Second, I installed following packages:

as it was recommended here for Ubuntu. I suppose, such packages can be found for Xubuntu too.

It's a key step. Fluent doesn't want to find, => not found => /lib/ (0x00007facb2ec9000) => /usr/lib/ (0x00007facb2ca5000) => /usr/lib/ (0x00007facb2a3f000) => /usr/lib/ (0x00007facb282d000) => /usr/lib/ (0x00007facb24f7000) => not found
though this lib is contained in /usr/lib (not? then

sudo apt-get install ia32-libs
It should be also noted, Fluent 64-bit needs that is 32-bit library, as well as standard x86_64 libraries.


sudo ldconfig -v|grep libstdc++
At last,

ldd -d /home/villager/Fluent/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3
All packages should be found.

This way I managed to get through all errors, but the evening was lost. Hope, you will too:).

All times are GMT -4. The time now is 16:40.